Stuck with Cloning Containers in Thunkable Layouts

Hi everyone,
I’m unable to locate the option to clone containers directly within layouts. I’ve tried various approaches, but nothing seems to work. It’s unclear if this is a feature limitation for free users or if I’m missing something entirely.

If cloning containers isn’t currently feasible, have any of you found workarounds to achieve similar results?

Thanks in advance!

Hi @longcodes22kpn5, welcome to Thunkable! :tada:

Be sure to check out our posts about How to ask Great Questions v2.0 and our Community Guidelines as you get started.

Cloning a contain within a Layout is possible and available to all users, you would just need to identify the container and Layout to clone.
Screenshot 2023-12-29 at 11.15.49 AM

Can you send us a screenshot of the blocks you are trying to use where this is not working?

1 Like

Thanks for your response!
I cant select the container as there is no option for it in the menu

@longcodes22kpn5 You might need to create a container, within the container or layout.
Learn more about the Layout Component here: Layout Component - Thunkable Docs

There are two containers in the layout

Can you send me the link to your project?
(I can’t edit your project, I’ll copy it and see what I can find)

sure! Please check the 2nd screen

This is strange, maybe try a hard refresh of your browser?

When I looked at your project, the additional containers were all in there.
Screenshot 2023-12-29 at 11.35.27 AM
Screenshot 2023-12-29 at 11.35.38 AM

Figured it out. You can select the things within the container. Like that button. The reason why its “ctrFave” in @matt_conroy’s picture is because he just named it that.

Strange as @matt_conroy can view the containers

I tried hard refreshing as well but still can’t view the containers

Works fine on my end… I can see the containers as well. What’s your browser? Is it up to date? What’s your computer?

I am using Chrome. I will try a different browser.
Is it a problem from my end though :sweat_smile: :sweat_smile:??

Send me a screen shot. What do you exactly mean when “I can’t see the containers”.

Heres what i see:

Can you try deleting and then creating the clone block again? It is difficult because we cannot replicate the issue.

In the layout, I have two containers,


now when I go to the blocks I can’t see the containers for cloning while @matt_conroy can see that (he sent a screenshot above)
I just see the component (button) and not the containers

Hope that summarizes my issue

I tried but nothing goes right!

Ok… Yeah seems like a Issues / Bugs
The fix to this is beyond my capability.

Report it to @matt_conroy (or other Thunkable Staff), if it happens again…

It might have to do with your project and not a bug, but not sure…

1 Like

Thanks for your time @emlee703!
Waiting for the staff to check on the issue.