Stage problem - white screen?

OK, I’m stumped. I had a game with a canvas, a stage, and a bunch of sprites. Everything looked good. Then suddenly the stage stopped appearing. I tried deleting and reinstalling Thunkable Live.

I added a new canvas. That one shows up fine. I painstakingly copied parameters from the new working one to the old broken one. Still not working. I added a new stage in the broken canvas. Still broken.

A border on the canvas shows up (and is correctly sized), but a background/frame on the stage does not. It’s like the stage isn’t loading??

Any hints or debug suggestions? If I delete the broken canvas, will I lose the sprites?

Updated: When I try to delete the canvas, my browser screen goes blank. ARGH.

OK, further weirdness: It also loads if I preview as responsive webapp.

Thought it was maybe my phone, so I tried on my iPad. Nope.

Made a minimalist project (screen with background, one sprite) - doesn’t appear on ipad or iphone, latest thunkable live.

Anyone else willing to look? Thunkable

2 Likes

So there is nothing wrong with the broken canvas?

I have the same bug.
Just An empty canvas with one Sprite.
And IT doesn’t appear.
Only the size and background color works.

I think this bug May have to do with the screen being scrollable, but I get the same behavior in my app without the screen being scrollable, so there must be a second bug.

I’m not 100% sure what is going on but happy to help troubleshoot.

Is the default height/width for the canvas supposed to be fill container or did you set it to that?

I think it was that by default

I’m closing my thunkable windows for the day. I was really happy with where I’d gotten to, and now it looks like I’m doing a total rebuild. Luckily, most of the work was graphic design stuff, but I’m going to have to re-enter a huge pile of sprite locations and sizes.

So it’s really weird. Fine in Web preview, not on iOS for my phone (with Thunkable Live).

Anyone else willing to test?
https://x.thunkable.com/copy/cb91b8a7ef4ad419e90f48d67b439363

@catsarisky and I have been discussing this on Intercom. I couldn’t see this behavior (ie the Stage looked normal to me) on my staff account, but I can see this behavior (ie cannot see the Stage) on my non-staff account.

I tried an asset fix on this project, and now I can see the Stage background even on my non-staff account.

Please let me know if this has helped you!

2 Likes

@jane , I checked all eight copies of this broken app (because I wasn’t certain which one you were viewing) and all are still broken for me. Have sent you a link to a specific one (wondering if you fixed a copy link?) - hoping that’ll get it!

1 Like

So my app is still broken (all copies, but just my app), but while trying to reproduce the bug, I found a new bug.

To reproduce:
Add a canvas. Set the screen to landscape. Load an image for the stage background. Mine is 2732 px wide and 1054 high. (This may or may not be relevant.)

Test (Live test, I’m using older iPhone and iPad.) Canvas/stage appears, but pretty small.

Change to 600, 1500. Test. Looks great on both. Oh but wait, newer phones have more pixels than my devices do.

Change to 800, 2000. Test. Both of my devices now show a white screen.

Back to 600, 1500. Looks great.

Would a few folks be willing to test this? I’m interested to know:

  1. What you’re testing on
  2. Do you see the same breakage with the stage set to 800px high and 2000px wide?
  3. What does 600px high and 1500 px wide look like on your device? Is the stage image using the full screen width?

Link: Thunkable

2 Likes

Android phone

Works OK.

[Edit]
I tried different sizes and could see the stage all the time.

1 Like

Hey there,

Since we’re discussing this on Intercom, I won’t carry out a whole parallel conversation here!

This behavior seems to affect the whole Canvas, not just certain background images. Unlike lukehoogenboom0i, I can’t even set the background color of a Stage in your project and see that background color when I test your project on a device.

I know it’s not a general issue with the Canvas, because I can build apps with a Canvas on staff and non-staff accounts and they behave as expected. If all of the projects you have shared so far are copies of each other, then this behavior may be project-level, but the bug is being copied over to each version of the project.

If you build a brand new project with a Canvas, and let me know if you can see that Canvas, that would help us identify if the issue is with the original project or if it’s on a larger scale. As I mentioned on Intercom, a Canvas with one Stage, with a background color, no assets and no blocks, would be a good minimal app to test this out.

To anyone else reading this, if you think you are seeing the same behavior (Stage does not appear at all, not even the background color, not even the background picture), please leave a comment!

2 Likes

try hard refresh

I had the same issue, but it fixed itself.

Jane, if you see my post from yesterday, I’ve got a bug in a fresh build, although only muneer reports trying it and it doesn’t reproduce on Android.

I’ve now rebuilt the project that seemed bugged and it is working ok. It didn’t seem like we were going to get a fast resolution on it. I’m being more careful about making backups, in case it happens again!

1 Like

I can see that you made a fresh build with the same background image. I would be interested in seeing if you can view the Canvas of a project where you have only set the background color of a Stage, with no assets uploaded to the project, and no blocks in the project.

If you were able to rebuild a project then the issue isn’t account-level. This is great! Could you send me the URL of the original project with a Canvas that didn’t display for you? I still want to see if we can identify the root cause, but I want to make sure I’m not looking at a copy. Thanks!

1 Like

Here ya go, @jane . This is broken on my iPhone SE (2016) and older iPad. Stage is green, border is red.
https://x.thunkable.com/projectPage/609d0eea0b85d10012885185

If I reduce the size, it shows up OK, but at this size, it doesn’t render the stage at all. I’m interested to know if it works on your much larger XR.

1 Like

@catsarisky
@jane

I tried the project on Android and its fine but out of curiosity, I revived an iPhone 5s from cold death to test the issue and this is what I got

Hope that helps.

1 Like

That’s what I get, too, @muneer. The 5s and SE (2016) are the same shape/pixels, so that doesn’t surprise me. Interested to see what folks with something big (X?) get.

Cathy

1 Like