Speech Recognizer - Android DnD Issue

Hi,

For me (Android) downloaded apk, the speech recognizer doesn’t request the user authorize the app to use the permission:

Just a button and a label. All I get is the error ‘…requires permission…’

The same code for StP does ask the user on first hitting the button.

Here are my results in Thunkable Live. I haven’t tested a downloaded apk file yet.

On my Android phone (OnePlus Nord N10 5G), I get the following alert when I tap the button using your blocks:

On my iPhone 11, I get two alerts asking for permission.

After allowing the permissions on each phone, it works to display the spoken words in the Label.

I also found the permissions setting on my Android phone in SettingsApps & notificationsApp PermissionsMicrophoneThunkable.

2 Likes

Thanks but I have never tried the Live App - always do an apk. I’d not rely on something which isn’t representative of the actual end state.

I confirm that I did the above test and the one from the other thread and in both cases, on DnD the permission was not requested whereas it was from Stp.

Of course I did look at the settings for each app. The StP one has a microphone permission in the list but the DnD version (code above) has only ‘Files and Media’ and ‘Phone’ listed on the permissions for the app (denied but available to turn on). Therefore for the exact same blocks’ intent, for me on my Android device (very new), DnD does not think it needs the Microphone permission…

1 Like

You’re right. In the downloaded .apk file on my Android device, there is no way to allow microphone permissions. The app itself does not appear in the list of Microphone apps. And I get the same error message you’re seeing “Speech to text requires permission to record audio.”

I’ve reported the bug here:

2 Likes

Thanks vm @tatiang

Is DnD labelled as Beta as it should be IMNSHO.

It had been but I don’t see that designation now.