[Solved] Web viewer not loading new URL

Hi, I set a web viewer to an initial URL. For the sake of testing I set it to https://www.bing.com/. Then, when the page starts, I set the URL again using the Blocks to https://www.google.com/. The problem is that the web viewer still shows the initial URL of https://www.bing.com/. I set one of the labels to the URL and I can indeed see that that the web viewer’s URL has changed to https://www.google.com/. I tried even to call the webviewer’s reload. However, it still only shows me Bing site and not Google site.

Screenshot 2023-07-22 at 17.44.19
Screenshot 2023-07-22 at 17.50.27

Here is the images of the code…

Can you share a link to your project?

How are you testing the project? In a browser? On a mobile device using Thunkable Live? Which device?

it’s a private project: Thunkable.

I am testing it on an android device using Thunkable app. The same happens when testing it using preview on web app.


Sorry, I am not sure if your answer is related to my question, or perhaps I misunderstand it…

I’m so sorry! I posted a response to another post here by mistake. Sorry for the confusion.

I’m not able to open that link. Do you mind sharing a new link?

Hi 20 days later i am still stuck on this issue. Here is a link: Thunkable

Could you please help me? I am trying to change dynamically the web viewer URL when the screen opens from https://www.bing.com/ to https://www.google.com/. (just as a test).

However, it does not change.

I think there was something corrupt in the blocks you had.

I replaced them with basically the same thing and it now switches to Google in Thunkable Live (it fails in a browser preview).


Hi @tatiang , thank you for looking at this. I still don’t know what’s the matter, but I copied your project and when I test it I get " www.google.com refused to connect." While un my original project I still don’t manage to get it working for some reason.

@tatiang @royrosemarin I’m sorry I did not see this earlier. For the issue where you are getting www.google.com refusing to connect. That is a CORS (cross-origin resource sharing) issue. Basically, Google and many other websites will stop components like a webviewer from viewing their sites across multiple servers.

OK, thank you @matt_conroy and @tatiang . I’ve now managed to get the same CORS response in my original project. This is very strange, becuase I only created this project as a toy example to show how my webviewer URL does not change in my other private project. Then, it did not change for me in the toy example, until you just recreated the blocks and then it worked. Anyway, at least it is working now, so thank you both!