[Solved] “There Was A Problem Parsing The Package”

Hi all,

I’ve a problem with installation app on Android.
I get always the message: “There was a problem Parsing The Package”. On IOS I don’t have any issues. But on Android, no chance.

Any idea?

Thanks a lot in advance.

Hi,

Is a simple empty application with one Label not installed too?

No. About 3 days ago, I installed the App without any issues also on Android.
Then I deinstalled the App again. Now I tried to install again, but no success. In any case, there aren’t installed any Apps without Label.

Something updated and broke the installation. I have not met with this.

Hi, i get the Error “Problem Parsing Your Package” when i export the App via QR code i also download the Apk file and then try to install, but get the same error. i then delete the App, upload the previous aia that i used for Playstore, again same error, ibut when i download from Playstore it work 100%. My phone s set to allow Apps from unknown sources so that is also not the issue. The Apk i downloaded from Playstore, is the same Apk i export to my computer, but yet i can only download it from Play Store without this error. Please help

Hi there,

I’m facing the same issue: “there was a problem parsing the package”.

I can install an old version, but the updated apk can’t be installed.

Has anyone solved this?

Thanks!

Hi @rpcosmo,

Welcome to the community :wave:

To begin, can you try downloading and reinstalling the app, if you haven’t done so already?

Thanks!

1 Like

Hi, thank you so much for your support.

I’ve done this.

I can install a copy of October 28, 2019 (40.5 MB). But the current version (47.5 MB) has this problem.

The current version can be installed on an iPhone normally.

Thanks!!!

Strange…can you PM me your project link @rpcosmo and I’ll take a closer look for you.

Thanks

Sure!

https://x.thunkable.com/projects/5c153d601e8307f11bfc7698/project/properties/designer/

Thank you so much.

Hi @rpcosmo,

when I try to open your project it takes forever to load and the page becomes extremely unresponsive - even Google Chrome alerts that the site is unresponsive and it completely freezes on the scr_principal blocks… On that particular screen there is also an error but I cannot try to get rid of that because it completely freezes…

53

However I managed to install your app anyways by changing the App Package name. I had to replace the last segment. There are some rules for application IDs:

  • It must have at least two segments (one or more dots).
  • Each segment must start with a letter.
  • All characters must be alphanumeric or an underscore [a-zA-Z0-9_].

@Domhnall this might be something Thunkable should implement since the package name was automatically generated by the system when I remixed it (com.gmail.christiancraik.6118tool)

@rpcosmo besides the above: do you really need dozens of screens?
I think your app is a little too blown up :grimacing: You might want to take a look at Domhnalls guide

Best, Chris

2 Likes

Hi.
Thank you so much for your concern.

This screen (scr_principal) has about 35 variables. At home, I can’t work on this screen because my connection is limited. Only at the university, where the connection is very fast.

This is an educational app to teach about the design of concrete structures to civil engineers. It is based on a Brazilian standard.

This needs very robust calculations. I did only a small part, and I don’t know how to soften it. How to decrease the amount of variables. How to decrease the number of screens…

Thank you so much to find this error. It works!!!

1 Like

Thank you so much.

@gre4t_wh1te gre4t_wh1te found the error. It works now!!!

2 Likes