[Solved] Parse Error: There was a problem parsing the package


Tried to download .apk app from Thunkable X to android 4.2.2. However, getting the error “Parse Error: There was a problem parsing the package”. The security is disabled on the phone and I’ve tried testing .apk from different source and they are able to install. Is Thunkable X’s version not compatible with older androids?

1 Like

Hi Terry,

Unfortunately, Thunkable X apps are only compatible with Android 5.0 and higher.
See the minimum requirements page here.

Do you have access to an Android device running Android OS 5.0 or higher to test this app on?

oh I see, ok I’ve tried it, worked on higher androids (9)

1 Like

I’m glad we could find an explanation so quickly!
I’m sorry that the app won’t run on your Android 4.2.2 device. :sleepy:

@jane On another phone, I’ve upgraded and custom installed 6.0.1 Android (custom CyanogenMod GApp Marshmallow) but it still getting the same error and unable to install apk, any other suggestions?

I’m thinking perhaps there are certain dependencies that Thunkable rely on when unpacking the compiled .apk

1 Like

Could you copy the URL of this app project from your browser and send it to me?

@jane it was a project released from the mailing list

1 Like

Hi Terry,

I think this behavior is related to your app’s package name.
Because your app is called 4Hire, the package name is in the format com.thunkable.user.4Hire.

The segments of a package name need to start with letters, not numbers.
Try changing that last segment to something like .hire or .forhire.

To find your app’s package name:
Click your app’s logo in the upper left hand corner of the Components window to open an App Settings window on the right-hand side of the screen.

In this window, you’ll see a property called App (Bundle) ID.
This is your package name.

Let me know if that works!


@jane wow ok it worked fine, both name and extension had to be none numerical

1 Like

I think the project name should be fine - did you have to edit it after editing the package name?

1 Like

changing the extension name alone, then apk install - did not work
changing the extension name and app name, then apk install - worked

1 Like

Good to know! Thanks :grinning:

Its working, its resolve my problem.
thanks dear.