[Solved] Problems connecting Google Sheets as Data Source?

Hi, is anyone else having trouble connecting Google Sheets as a Data Source? I click “Sign In” and briefly see a new window, but it disappears almost immediately. After clicking twice, it throws a 400 error code.

I’m using Brave (v1.42.86, built from Chromium: v104.0.5112.81) on a Macbook Air, running Monterey v12.2.1. I also tried it in Safari v15.3, with similar results.

Using the browser’s “Inspect” tool, I was able to get the redirect URL which shows the Sheets in my Drive, but selecting one didn’t surface a path to go any further.

I noticed @muneer had a similar issue last year and contacted Thunkable to reset credentials, but I’m using a free account during dev.

Any other ideas?

I’m not having that problem but I would recommend clearing your browser cache. If that doesn’t fix it, try logging out of all Google accounts and see if that helps.

Thanks, @tatiang. I cleared my cache, logged out of Google, then tried Brave and Safari again.

Safari gave the screens below (cookies are enabled, btw), but neither browser allowed me to connect Sheets.

Hmm… I’m not sure then! Hopefully someone from Thunkable can help reset this for you.

1 Like

Hi,
Do you have any sort of ad-blocker or ad-pop up disabler enabled onto your browser? If so, could you try disabling any of those blockers and try once more?
Thank you

1 Like

Try this

Thanks, @brianl. The Brave browser is hyper-diligent about ad blocking, so turning it off for that tab did the trick.

And I appreciate the help, @tatiang and @jared!

3 Likes