Google sheets bug?

I am struggling with uploading a google sheets, this is what happens when i try putting a google sheets in, please help

Are you using the “add a data source” button on the left side? Can you be specific about how you’re triggering this error? I added a google sheet data source as recently as last night (I think), so I’m not sure what’s up here?

1 Like

i am using the plus button here >>

I just tried adding a data source to one of my projects, and it worked fine. Perhaps retry?

1 Like

i retried many times…
if it’ll help any better here is a vid retracing my steps exactly

Talk to the Thunkable team to get your credentials reset and you will gain the access again.

1 Like

Ah hah! I can reproduce that error if I’m logged out of my google account. Go to and sign yourself in. Then try again - I think that’ll fix you up!


It happened to me couple of times. If you try to connect to a Google sheet from a different account you will not be able to go back to your account.

Or at least this is what happened to me.

1 Like

Yea the issue is still happening…

1 Like

i could before even tho both the data sources are from a second account that its google sheets are linked

1 Like

Hi there,

I just sent you a private message about resetting your Google Sheets authorization.

Hopefully resetting the connection will resolve this behavior for you!


1 Like