Having a lot of troubles with Data Source

I am having a lot of trouble creating my own data tables in my data sources. I create them, they seem stable, and at the moment, or the next day, they are deleted, although the database is still created. I don’t know if it’s a server issue, but it’s really frustrating.

Are these local data sources within the project or cloud-based data sources? Are you using a single table/sheet or multiple within a single data source? Are you importing from a CSV, copying and pasting data, or using special characters at all?

When do the errors in the screenshots appear? Is it when opening the project, editing it, previewing it, attempting to view/edit a data source?

Do you have a sample project you can share that has this problem?

Are you still having this issue?

Hi, Tatiang,
These are local data sources within the project, copying and pasting data from my Excel file to my computer, to do the typical quiz exercise.

And yes, Jared,

I still get the same result: in a few minutes, the app I’m making in thunkable seems to reset, and back to the missing content of the database I was trying to create.

I’m still having the same kind of problem with the Thunkable database. Is there any kind of limit with the files or something I don’t know?
I can’t even Create a Data Source from a Google Sheet, because the select a sheet button doesn’t work… And it’s been like this for almost a week.

If you’re seeing this, it is likely that you are experiencing issues connecting with your google sheets account.

Refresh the browser

We recommend refreshing your browser. This sometimes fixes connection issues that users experience. Sometimes a “hard refresh” of the browser is required.

These are also known as a “force reload” or a “force refresh” you can use a hard refresh your browser to ensure that you are seeing and using the latest version of Thunkable and that any cached data that could be causing a connection issue is wiped clean and freshly retrieved.


The keyboard shortcut to hard refresh your browser is Ctrl + F5. You screen will blink momentarily and the banner should disappear. If not, try clearing your cache.


On a Mac computer you can use the Option + Cmd + R shortcut to force your browser to refresh. If this does not work for you, try clearing your browser cache.

Refreshing didn’t work for you?

If the above does not work to get your back to Thunking with your Google Sheets, then we recommend the following steps. First, let’s acknowledge what a pain this is and please know that we are working to fix this. The issue lies in the fact we are using two systems that are out of sync, hence we are working to identify a solution that will work for the duration.

Step 1: Remove Thunkable from your approved apps in Google

If you gave Google Account access to Thunkable, you can remove its access to your Google Account. Thunkable won’t be able to access any more info from your Google Account, but you may need to request that they delete the data they already have.

  1. Go to the Security section of your Google Account.

  2. Under “Third-party apps with account access,” select Manage third-party access.

  3. Select Thunkable.

  4. Select Remove Access.

Step 2: Delete your data sources from the ‘My Data Sources’ tab

After logging into x.thunkable.com you will click on the ‘My Data Sources’ tab. Delete each of the data sources associated with the linked Google account by clicking the trash icon on the far right of the data sources row.

Step 3: Email Support

Email support@thunkable.com and let them know that you need us to reset the google sheets token. be sure to email from the gmail email that you made the connection with.

Step 4: Add your data source

Now you should be able to authenticate with your Google account appropriately and connect your sheets to your apps again. If you are experiencing any further issues at this point after following the above directions, please reach out to support@thunkable.com and a team member from Creator Success will follow up with you directly.


Thank you. I’ve followed the fist three steps of your directions.

Hi Jared:
I did what you told me, but I still have problems, and nobody seems to respond: It won’t let me create a database in Google Sheets, nor in the app, nor can I access the previous ones, since I deleted them as you asked me, although typing “thunkable” in google, enters directly into the application and does the sign up without asking me for any data. I haven’t heard back from the helpdesk since last Friday…

Hi Jared, Sorry to bother you once again but something went wrong. Now I was able to create the database in Google Sheets, but when I want to use it, the program crashes completely and gives me a blank screen…
When I try to see the contents of the database in the Data source of the program, it is empty, as you can see, or it breaks.


It works fine with airtable, but I also need google sheets

Sorry to say but I’m checking and it only imports 100 rows from each airtable database. Larger Google sheets files break, and smaller ones only import those same 100 rows.

And the server is very, very, very slow

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.