[Solved] Listviewer does not appear on phone

Dear All,

Have put listviewer in my app and works fine on browser where I can see it on the browser but not on the mobile.

sharing the screenshot:

Android Phone:

Also noticed in the textitems of List viewer ,it says undefined though after I click then it get changed as Empty string later it moved to undefined. is this a reason why its not showing on the phone?

Your input is highly appreciable.

Regards,
Sasi Preetha

It’s going to be very hard to troubleshoot this without seeing your project. Are you able to share a link to it?

https://x.thunkable.com/copy/e36bbfe3b82281b38fa70497dc024138

Here it is…

The properties panel only shows the initial value you enter. It won’t show “live” values after changes are made.

1 Like

The List Viewers are not showing up on my iPhone either. I even tried this and it does nothing on my phone (but works in a browser):

image

@conroy are there known issues with the current version of Thunkable Live? It seems pretty unreliable. I’m having to force-quit it constantly just to get it to update and the browser often hangs when trying to Live Test. I wasn’t having those issues before.

2 Likes

What happens if you download to the Android device? So not using Live app.

1 Like

@tatiang @sasi.preethag3yh None that we have been made aware of, from here in the Community or otherwise in our other support channels. But I am seeing the same issue with the listviewers not appearing on iPhone or Android.

As @martint suggested, just downloaded the apk to test this on Android. The list viewer is not working there either. I am going to try and replicate with an MVP and report from there if the issue persists.

3 Likes

There must be something going on here in the blocks that is not allowing the list viewer to display. Here is a small sample app, no issues getting the list viewer to work when set up similarly to @sasi.preethag3yh’s app.

I would try and remove the extraneous stuff not related to each list viewer (calculations, etc.) and see if something in each row is causing the list viewer not to display and then build up from there until all of the rows populate with list viewers. You could then add back in the functions and maths and see if something there is causing an issue.

https://x.thunkable.com/copy/433e2b2f5c5ba98f8459902ca4a27bb5

1 Like

Phew… finally found it. It’s all the spacing problem . List viewer needs full space:)

I kept the List viewer inside column where the column is inside row though column height is fill container.

After I kept the List Viewer outside of the row, I could see the listviewer appearing on the phone.

Sharing the screenshot

Thank you all for your time to share your views to get this fixed. Much Appreciated. Thanks again:)

3 Likes