[Solved] Is anyone having issues publishing Web Apps right now?

Is anyone else having trouble publishing web apps right now?

I can preview them no problem, but can’t publish

1 Like

@jared I dont have any problem with it,
I’ve just published my web app to test.
https://thunk.app/web-build/index.html?webAppId=xmrjISIf7

Thanks for the response, @justin.thanh84v20

I get an error when I try to publish the app from my phone or my computer. I will try a different browser I guess

on when i load the app only, in my console I recieve this error

when i click publish as web app i get this error

there are 0 ‘not accepted’ components either. I am moving everything to a new screen and will copy it to a new project and try that.

I have no problem with chrome
I have same error when look into the console
but I still can public app normally
Screen Shot 2020-04-25 at 23.14.09

so strange. must be something with the coppied blocks/screens I was using.

I just copied only what i needed to new sscreens. saved those screens and now it works.

check it out! (this is all sample data, but it gives the idea)
https://thunk.app/w/hAxW2SzCk

2 Likes

it worked,
and I think you should highlight the selected item,
or change the behavior of list view when clicked on it,
first four items of behaviors have same sub-item is count, so I have some difficult to use it =))

1 Like

grr! I published 2 hours ago. Now the version that was published 2 hours ago, wont publish. I’ve made no additions. only block changes. All works in preview and on my phone. If anyone else could test this issue, that would be great.

I have messaged the admins on the chat channel about this. will follow up on the github in a day if not resolved. This will be awesome when it works perfectly!

Hay alguna forma de publicar mi app en version web pero bajo mi propio dominio?

Creo. Si compra un nombre de dominio, debería poder establecer dónde el dominio ‘apunta’ o redirige el tráfico. Debería poder configurarlo en la URL de la aplicación.

@jared both Web Apps (Responsive and not) publish fine for me too.

(edit)

Tested only a couple minutes before sending this post.

1 Like

bummer. I think I may need admin support on this.

the issue would make a lot of sense if i knew what was going wrong. I’m just not sure where it lies. I dont have any ‘unallowed’ components. i’ll keep trying

1 Like

Did you try a hard refresh of chrome? Maybe log in on your phone and try publish from there to see if the browser itself is buggy.

(edit)

I am now experiencing reloading/refresh issues with the app (i.e. Refresh button causes error code in chrome. or when adjusting the tab size it will not reload to fit the new window). Loads fine first time but that’s it :slight_smile:

yeah. good qustion. Still not working. I tried on safari. I get this repeatedly

even after removing what I added after the first publishing

is super frustrating. I wish there was a debug console for these types of things.

@jared I just edited my post above with new information.

will try that too. I also tried safari.

I also can’t seem to produce a share link…

I may need assistance beyond the forum.

So then I tried to copy the project and received this error

[even more updates]

still cant copy the whole app, but i can copy the only screen

I copied that same updated screen from this 1 screen app that I couldn’t publish. i copied into a new app. and it works just fine now

https://thunk.app/w/93aMz06gj

1 Like

what is the url of your project?

Thanks for looking into this @paulmw,

the one that works currently is here
web app https://thunk.app/w/93aMz06gj
project link https://x.thunkable.com/projects/5ea4b1625d88d7ddbe2b35b8/167d1e14-9c2e-40c4-80ed-f9f65686e8a3/blocks

the one that produces errors
web app https://thunk.app/w/hAxW2SzCk
project link https://x.thunkable.com/projects/5ea4632f90beb22e7bd4fcc3/6e537979-4be7-42a5-9801-cd7fdbbcaf13/designer

Does the one that produces errors work now?

weird. I actually tried that one last time right before I posted that and it produced the error.
@paulmw any ideas abotu that?
did it just need a gentle admin lookover?

i have been able to test publish twice now since you posted. that’s so weird. it was not allowing it for quite some time. The system even disallowed making copies of the app and only permitted copying screens.

1 Like

I’m not sure what causes that problem, but we know how to fix it (it’s something I can quickly fix as an admin). Sorry it took us a bit to fix it for you.

3 Likes