[Solved] How to send a text message

When I use the Send Text Message from within a Share block, the screen just flashes but no text is sent and it doesn’t open the Messages app on my iPhone. Do I have to enable something else?

I’m guessing this is yet another bug (based on Unable to send text message from Android)?

I haven’t tested this is a while @tatiang but can take another look for you.

Are you using Thunkable Live or installing your app on a physical device?

@domhnallohanlon Both. Thanks for taking a look.

1 Like

The problem I’m having has something to do with the loop I created before the text message call. When I just have on click --> send text message, it works. So I’ll need to troubleshoot this a bit.

1 Like

Hi, @tatiang! :wave:

If it’s possible, could you please post a screenshot of the blocks you used?
So we could have a better look on your loop :+1:


You know, I got it working and I’m honestly not sure what the problem was. I tried a few variations and it just seemed to fix itself. I wish I could say what I changed!

Here’s the working version:


Nice - Glad to know that your problem is Solved :+1:

Please mark your above post as Solution :white_check_mark:, since your problem is solved :+1:
This would mark this topic as Solved in this Community :+1:

Thanks! :blush: