[Solved] Get names from Airtable list

Hi!
Iḿ trying a simple task, but all the tutorials are using blocks I can’t find in my panel.

I’ll explain myself.
there is a table in Airtable with 2 columns: ID and Name. I have already linked the table to my app.
When the user insert the number of ID in a Text Input, the name related to that ID is shown in the text label.

I’ve been reading this: Airtable - ✕ Docs but as I said, some blocks aren’t present.
Thanks in advance!
Pablo

1 Like

Are you using the legacy UI or drag and drop?

2 Likes

With Airtable there is no easy way to do a lookup unless you use API or you use the old method of looping through the records and comparing values till you get the required one.

In the other hand I would recommend to use a column name other than ID such as UserID because ID is a hidden name in all Airtable tables.

1 Like

How are you doing this @pbuydidm ?

I’m assuming your IDs are unique, right?

1 Like

@pbuydidm
See this code. This is working for me. I search for phone numbers but of course you can change the code to your needs.

1 Like

Thanks a lot!
I just changed the things according to my project and it worked perfect!!!

Thanks! :slight_smile:

1 Like

Legacy.
But I made a mistake when asked. Some blocks were not present because I forgot dragging the airtable component to the app. Sorry :man_facepalming:t2:

Thanks @muneer
But your suggestion worked for me.

Hi @domhnallohanlon
Yes! I loaded the info about my airtable.
I was wrong with the blocks I couldn’t find: they were there. I just forgot dragging the airtable component to the app :man_facepalming:t2:

And @muneer gave excellent guidelines. The project is working

1 Like

Its not working for me I can’t see the problem tried with airable and A GOOGLE SHEET

Screenshot 2021-02-06 at 19.21.57

1 Like

Can you explain more?
Can you give a copy of your blocks?

Hi Muneer
thanks for the response sorry I had uploaded the blocks but must have timed out. see below. I have tried several ways including loading to a list the results and to a database, nothing seems to work. I know there is an issue with some data types saving to airtable as I have another app that was having issues and it’s now logged as an issue so wondering if it’s something similar? I have spent several hours trying different solutions

1 Like

@Tina_Fountain
Yes this will not work. There is a restriction / limitation in the way the Airtable data is accessed. We can only get the data from the table if we supply the unique row ID generated by Airtable.

image
In your block you are retrieving the list of “Grp” which cannot be used as row ID.

Your work is all good but you need to change “Grp” in list of values block and instead use “ID”. If you do this change all will work in the expected way.

Happy Thunking

Brilliant, I had actually tried that, but I think I must have messed up somewhere else on that occasion it’s working now. Thanks so much

1 Like