[Solved] Data Viewer and Google Sheets

Still have a problem with google sheets. When I start to create a new data source with google sheets, I am asked to log in with my google account. Then a pop up window shows, but only for a very very short moment. Trying to log in again, the same. After the third attempt to login, an error is shown.
I tried it on Safari, Opera and Chrome on Mac OS and iPad. Always the same problem.

Hey @rollke

I think it’s best to create a dedicated topic for this so that it doesn’t get lost in the announcement topic.


Can you tell us, or do you have a screenshot of, the error message please?

Do you have a pop-up blocker?

Have you tried doing a hard refresh to make sure you’re on the latest version of Thunkable?

1 Like

see my post
Data_Viewer Google sheets

Still can’t select a table.

When I click selected table drop down it says…Pick a data source first to fill in the data! I have a personal Gmail, hard refresh, cleared my cache, deleted all sources, deleted/removed and re added component… This feature would be a big help for me and i’m itching to use it but I cant : (

Also for me. I already tried the same.

Same boat here… following…

Same situtation for me (I cant see Columns Names)

  1. I didnt delete Data Sources Name of Veriler


  1. Why i can’t delete Data Sources from Here and seeing lots of same Data Sources too.

I did


A post was split to a new topic: Connecting Google Sheets to the Data Viewer

This is what happens, when trying to connect Data_Viewer to a new source of type Google sheets:

Bildschirmfoto 2020-05-18 um 12.33.47 Bildschirmfoto 2020-05-18 um 12.34.00 Bildschirmfoto 2020-05-18 um 12.34.11

For me too. I cant connect Google Drive. I already reset cache and everything that I saw in discussions…

@rollke @ubimidia are you trying to connect to an @gmail.com address or do you have a Gsuite address for work/school?

Regular Gmail

I try to connect to a regular google mail address

But the main problem for me is: The dialog for login to my google account appears and does not let me log in.
When I click on „Anmelden“ (log in) then a windows plops up very short and disappears. I can do that twice, then the error report comes.

Is someone in the community who is able to connect to a google sheet. And if yes, how?

have you tried making your google sheet public? I hear this works haven’t tried it yet…

I have the same error! I cannot even access the Google Sheets!

That is exactly what happens for me.

The dialog for adding a google sheet now changed.
There is a new button „select a sheet“.
That is nice, but the problem to sign in to google after pressing that button ist still the same.
It is not possible to sign in. See older posts.

@rollke are you using a new project for this or are you trying to load the data into an existing project?

I did it with existing project, with empty project without any element (only try to add a source) and with new project only with a data viewer element. Tried several browsers on Mac and Ios. Always the same.

The „point of problem“ is the dialog after the add/googlesheet/select a sheet dialog.

When the dialog to sign in to my google account lets me select the „sign in button“ appears, then the appropriate dialog pops up and immediately disappears.

I was able to log in to Google Table from a different account.

  1. Log in to your Google MyAccount account and select the option - “Log out of all accounts”
  2. in the same browser, open Thunkable X with your YouAccount account
  3. In the same browser, log in to your Google Drive YouAccount account
  4. in the Thunkable X app, try connecting to the table.

After completing these steps, everything works fine for me