[Solved] Thunkable Data Source not Working Properly

I have just created a new project and add a google sheet data source. I added a data viewer list and select my google sheet as data source. The problem is I can’t select table in data viewer properties. I can’t select title property and subtitle property. Message showing is “Pick a data source first to fill in the data!”. Please help me in this regard.

Can you show us what the Google Sheet looks like?

My Google Sheet Looks Like this:

Sheet # 1 (SearchName)

Sheet # 2 (SearchMonth)

Sheet # 3 (Dec-2023)

I have 24 more sheets just like Dec-2023 Sheet (Dec-2023 to Dec-2025) and one hidden sheet named Lists.

Try going back to the Google Sheet in Datasources and click Sync with source at the bottom of the screen to see if that makes any difference.

There is no option in Datasources (Sync with source) at the bottom or anywhere on the screen.

I would suggest deleting the source and recreating it to see what happens.

1 Like

Problem is solved. I opened the .xls file in Google sheets and save as the file as Google sheet. The .xls or .xlsx files are not working we have to save the file as Google sheet. Google sheet as data source now working perfectly.

Thanks Steve for your response.

1 Like