[Solved] App not working without any changes made

I have not changed any of my code but the app that I created (that used to work) is now not working.
Even the very basic function of taking a photo and having it displayed is not working.
please help!

I’ve discovered that the functionality works in the “live test on device” but not on the “web preview” which I use on my tap top to test

Hi @infoyz8a, thanks for reaching out!

Please read these posts so you know what to include in your posts and how to ask great questions: Community Guidelines
How to ask Great Questions v2.0

Are you seeing an error when you try to run your project? What are the blocks you are using to take the photo?

thanks for replying.
The app used to work on “web preview” and on “live test on device”. I have not changed any coding and now it works on “live test on device” but not on “web preview”

You’re uploading the photo file here to Cloudinary?

I did just discover an issue (on web only) where we are getting a console error when trying to upload an image to Cloudinary. But it does work on Android/iOS/Thunkable Live.

Could you open your browser console and let us know if you see an error message there when you try and upload a file?

You can find info on how to access your browser’s console here.

I opened the browser console and tried the web preview, I do not know where an error should show, but I didn’t see anything.
When I try the app on my mobile device it works, but when I try to test the app using web preview on my laptop, I click on take photo, the camera activates, but then nothing else happens

That is fine, we have confirmed the issue with Cloudinary uploads via Web on our end.

I have reported this as a bug. Thank you for raising this issue to our attention. We will work to resolve this as soon as possible.
In the meantime, feel free to reach out for updates. Otherwise, I will reach out here when I have more information to share with you via updates or a solution going live.
Thank you, again, for your time and patience in this matter.

thanks for letting me know

The fix for this issue is expected to be released this week.

Ok thanks

Still not resolved! Not acceptable that you make changes and then throw hands in the air because Cloudinary must now make changes.
Sort the issues before you do new releases. This is extremely annoying, been more than 2 months that users can not add attachments in my app.

I do apologize for the inconvenience. We ran into some issues with Apple that have caused a delay in releasing this fix but it should be out very soon.

Never once have we thrown our hands in the air. As soon as the issue was identified, we immediately flagged this as a bug and got to work on resolving the issue.

Our engineering team does everything it can to ensure that bugs are resolved as quickly as possible. Unfortunately, even with the large amount QA that is done with all releases, some issues can not be forseen.

Thank you for your feedback!

@jp.leriche8ms5h @infoyz8a Thanks again for your patience. I would like to let you know that we have now officially released a fix for this bug.

Please keep in mind that you may need to do a hard refresh of your browser for the changes to take effect in your project. If this issue is present on the Thunkable Live app, you will want to update that that through the App Store and/or Google Play Store before any changes will occur. If your downloaded or published app is affected by this bug, you will need to re-download or re-publish your app for these changes to take effect.