[Solved] App crashes when using Image Picker in iOS 12 [Aug 2022]

When using the Image Picker / Photo Library component, it gives me an error and the companion crashes.

Error message:

My app is simply trying to pick an image… upon retrying same error occurs

Device: iPhone 6Plus
iOS Version 12.5.5

Edit: Tried on a test project. Same Error.

Testing on Android: Works as expected. Seems to be an iOS problem.

1 Like

Hi :wave: @sai1910

Sorry you’re seeing this today. Can you share a minimal example of this issue?

Is anyone else seeing this?

1 Like

All I’d tried with was:

Which gave the issue.

Can you create a minimal example? It’ll help Jared and his team fix the issue. I have an image picker in my app and just tested and it works fine for me.

Here: test.

I think the problem may be specific to my device (iPhone 6Plus, iOS 12.5.5).

Just tested using your project, it worked fine for me. So it might just be your phone. Do you have the most up to date thunkable companion app?

1 Like

Yes, the companion is up to date.

1 Like

I also just tested it on an iPhone 11 Pro and it worked out fine. So it night be something to do with your phone. Do you have the most up to date iOS? (Trying to find things to help) Also maybe restart your phone :grinning:

1 Like

iPhone 6plus only supports up till IOS 12.5. Can’t update further than that.

Will try restarting.

1 Like

Found this on GitHub. Seems to be the same issue. How can this be fixed on thunkable?

Thunkable Team, any update on this ??

Have you been able to reproduce this on any other device besides the iphone you own?
I know we all don’t own multiple devices (I don’t) but perhaps have people you know try it?

Hey @sai1910

We recently discontinued support for iOS 12 in order to upgrade some other parts of the build process. Sorry for the delay to a response. So sorry for the inconvenience.

What kind of app are you building? Are a lot of users experiencing this?


Currently just testing the app. It’ll be used by many users, but the ImagePicker functionality is only for the admins of the App. So hopefully this won’t be a big issue.

No, works perfectly on Android and on iOS 14 device.

1 Like