[SOLVED 1/31/24 7:37 AM EDT] Using Airtable in my Apps

Ciao.

Is anybody so kind to help me find guides, tutorials and docs where I can learn how to use Airtable DB on my Apps?

Grazie

If you’re starting out with Airtable, you might consider using the Airtable API and filterByFormula. It’s fast, powerful, and flexible.

See this topic for my response and the working blocks: filterByFormula via AirtableAPI

2 Likes

Thankyou Tatiana, but there is still something I don’t understand:

  1. I’m using OATH: which is the “WEB_api URL”?
  2. I have this simple table:

    The query I’d like to get with block is:

Select *
from Table
where atlCategoria=“B1” and atlDataAbbandono=0

Can you show me please a simple example in blocks?
Grazie!!

To get all the access info, like the web URL, i found very useful these docs:

Go to Airtable page, top right corner click on your personal image/account > Developer Hub > On the left, under “Resources” click on “Developer Docs” > select “WEB API” from the 4 options > Scrolla down and select your Base > go to “Authentication” field

Everything is written there, they teach you also how to do simple tasks

Hope it helped

1 Like

WOW, is sounds good!
But I still need bases… In this block:


which data I have to set in URL and Authorization??

Grazie!!

You can set the base directly in the URL.
You can either write the Table ID or the table name

ex.

api.airtable.com/v0/APP_ID/TABLE_ID

At least it worked for me, but i suggest you to go through teh docs i sent you, everything it’s literally written there

1 Like

Maurizio! Your opened me a new world! Grazie!!

Now I’m able to do the basics I need, but there still one thing I’m not able to: is it possible to set a query with more than a single “filterByFormula”?
This is the case:


Running, the App goes in crash… Where is my error?

Grazie

You can use OR and AND statements inside of the filterByFormula property. You can see an example here: The AirTable API (a more efficient way to integrate AirTable with Thunkable) - #22 by jared.

1 Like

Ciao!

On Creating a record:


I get this error:
{“error”:{“type”:“INVALID_REQUEST_MISSING_FIELDS”,“message”:“Could not find field \“fields\” in the request body”}}
Where is my error?
Grazie!

Ciao.

I understamd that my problem is to write on tables in Airtable.
In effect, further than having problems with writing new records, I have also with updating ones, with the same error:

{“error”:{“type”:“INVALID_REQUEST_MISSING_FIELDS”,“message”:“Could not find field \“fields\” in the request body”}}

(updating bloks)

The “delete” function is ok!

Can you help me please?

Grazie

Hi,
i’m just having a very quick look, did you add the Web_API Header with the component for the authorization and the “Content-type” ?
image

Hopefully it will help

1 Like

Grazie Maurizio!
I missed the “Content-Type” component!

:hugs:

Well: the more I use Airtable the more I have questions…
I creates an “attachment” field in a table where I wanted it to store pictures:

then in the blocks I take a picture and I want to store it in the “atlFotoQui” field:

But when I try to write the record I get this error from Airtable:

{“error”:{“type”:“INVALID_ATTACHMENT_OBJECT”,“message”:“Invalid attachment for field atlFotoQui: parameters must be objects, not strings”}}

Where is my error please?
Grazie

To make sure someone can help you properly, i suggest you to check the answer you found useful and solved your problem as “Solution” and open a new topic in the Community with a relevant title.

It will help the community itself to provide you the help you need and involve more people based on the updated question

1 Like