Simple Google Sheet - writing a row

TLDR: Use Chrome, not Opera, when editing Thunkable.

PROBLEM:

I’m new to Thunkable (from bubble.io), trying to add a new row to a Google Sheet. I’ve successfully connected my Google Sheet as a data source, and wrote the code in the image below. Thunkable can read the header row. But when I try to add a row, nothing happens. (I see debug text “begin writing…” , but not “wrote Google Sheet”. The Google Sheet doesn’t change).

I demo the problem in a video at https://www.dropbox.com/s/1f50r0gmbiewp7g/Thunkable%20-%20Opera%202022-03-18%2017-17-27.mp4?dl=0

  1. Am I doing this right? Is there something else I need to do, to push data from Thunkable to Google Sheet?

  2. how can I debug this? Is there any way to see if a block is crashed, throwing errors, is frozen or stalled, is waiting for an external call to complete, or has silently failed? Is there an log or any debugging tools? I looked in “Debugging” in Docs and iddn’t see anything like that.

  3. is this likely to be a sync problem? or access problem? I refreshed sync in Data Sources. That seems to work fine (when I change header rows in sheets, Thunkable shows the change)

  4. any tutorials or guides on writing to google sheets? I didn’t see much on the forum, docs, Youtube (mostly folks using 3rd party APIs instead of Thunkable’s built-in access)

I’m about to give up and struggle through learning Firebase, which everyone here seems to prefer, but I prefer to stay with Google Sheets because I know Google Apps Script, and my users already know Sheets. (I have read that I can export Firebase to Google Sheets, but would like to avoid an unnecessary step)

1 Like

What happens if you replace the UID value in the create row block with a text string (e.g. “none”)?

If that works, then you probably need to check for a null value in your stored variable:

1 Like

Thanks for suggesting something.

I replaced the stored variable block with a “none” text block, and it still didn’t work.

Any other suggestions?

Any thoughts on my question #2 about debugging? or #4, on existing tutorials for using create row to write to Google Sheets?

I tried it in Chrome, on a hunch, and it worked!

So, I think Opera is not fully supported.

I hope that goes on a FAQ somewhere, if it’s correct.

1 Like