Sign in not working in my main project

Hello, just wanna ask if one api can work on mulitiple project? Cuz after making a copy of that project with firebase api, the previous one of sign in doesn’t work any more. Or is the project corrupted? Please answer.

What APIs are you working on?

Does your API have request limits? Some do, i.e Airtable APIs has restriction of 4 requests per sec.

1 Like

Firebase sign in component. It worked well before, but after i make a backup, it doesn’t work any more.

This morning (@+8 GMT), I had the issue of signing on my app (with firebase authentication ) also. Similarly, it worked yesterday, and initially my other apps using the same Firebase authentication credentials were working fine. Then I realised that if I were to “live-test” the other apps, They too become broken. Now after painful investigation, I found out that my issue was due to blocks related to “stored” variable when I store username and password locally and reading text input from the text_input block. So what I did was to use another intermediate “app” variable to process reading text input and than save it using another block.

If you are using “stored” variable to store users or passwords, then maybe you want to look in this area. Nothing to do with firebase API.

1 Like


  1. I made the store value with the local storage today, which I have deleted afterwards.
  2. I am in GMT +8 (Hong Kong) too.

Is that working for you?

1 Like

I’ve been having the same problem since yesterday.

1 Like

Yes. Just finished fixing it. I ask Thunkable if there were any updates done that may have caused this but haven’t got any replies yet.

What I did was make another set of “app” variables to do all the stuffs. And then when done, assign the value to the “stored” variable… more blocks and steps but that fixed it.

Its past dinner here, have you had yours? :grinning:

1 Like

Wow, I have at least 20 variable in my app…

Guys, I manually type my email and password to the block and it is working suddenly.
When I use text input to get text it failed???
My brain :exploding_head: :exploding_head:


Wow, I have at least 20 variable in my app…

I have to do this for all the variables that have interactions with the text input, slider input etc… the rest are fine. This was the second time my fully functioning app broke down.


I think this might be a new bug.
Maybe thunkable just update to a newer version?
Today I updated the new version of live test app on play store.

Frustrating yes I know… but at the point when I realised the problem, I was not so stress anymore. haha


1 Like

The Firebase had been down for a few weeks. Now it perfectly works.