Rename [gear] list block to make list block

I’d like to see the name of this block change:


There are enough users who assume this is needed any time you are using List blocks in Thunkable as evidenced by these recent topics:

You can see an example of a mistaken use of this block after app variable TemplList had already been initialized/set as a list:


I think it would help new users to call that block “make list”. It could look like this:

Edit: or even “new list”. I’m trying to think of wording that implies it’s only for setting/initializing blocks. I realize that’s not entirely true but for most people, that’s what they will use the block for, if anything.

Hello @tatiang :wave:
Thank you for sharing feedback about the block name.
I will flag it to the team!

1 Like