Publish not work Please Help

I really need help on this I can’t figure out what’s going on, I am using the snap to place editor and my app has reached a state where I am ready to publish it to the stores. I downloaded the .AAB file and uploaded to an internal testing release so I could test it, but when I went to open my app on my phone after downloading it from the play store it gets stuck on the splash screen. The app works flawlessly on both the live test app and the web preview. I don’t understand what happened.

here is the project Thunkable

Hello @mikaydengutierrez33v

I am sorry to hear that you are having issues with testing the Android app.

Could you please check the Android App ID and AdUnitID (Android)?

image (88)
image (87)

Hi, thanks for the reply. I actually solved this issue, the problem was one of my variables being named “password”. I changed the variable name to “password1” and it solved my issue.

Hello @mikaydengutierrez33v
I am very glad that all your technical problems are resolved!
Thank you for sharing what was the issue and how you resolved it!