[SOLVED] Thunkable Sends APK instead of AAB

Hello everyone,

i have been away for few months and seems like i forgot few things or maybe something has changed.

I remember that when i was publishing/updating an app on Play Store, i had to upload a .aab file (or something like that).
Right now if I push the button “Publish Android” on Thunkable, it sends me an .apk file that seems to be recognized when i upload it.

Did someone have a similar issue?

i receive APK file either if i click on Publish>Android or Download

Thank you very much!

Hello @maurizio.polverini89
We can understand that it is frustrating and appreciate you taking the time to investigate and provide more information.

We have flagged it to our engineering team and will provide an update as soon as possible.

1 Like


I am facing the same problem here unfortunatly.
I dont even remeber how i solved it last time, few days ago.

When i press “Publish>Android”, i get a APK file instead of a AAB

i tried again, but still facing the same issue unfortunatly…

Same here.

@classlessteacher Welcome to Thunkable :tada:

We appreciate you flagging this issue. As mentioned above, we’re still working in isolating the root cause of this issue. In the meantime, can you try using a different browser or restart your default browser and try again? We have seen users have some success after trying one of these two things.

Thank you!

@matt_conroy No problem, just wanted to indicate it wasn’t an isolated incident. As a temporary solution, just pressing the publish iOS (without going through any further steps) seemed to correct it.

Thanks for the tip!

Hello, thank you again for your patience. I would like to let you know that we have now officially released a fix for this bug.
Please keep in mind that you may need to do a hard refresh of your browser for the changes to take effect in your project.

1 Like