Problem with SHA1/keystore

I’m trying to upload another version of our app to Google Play store. What I did was make a copy of the original app. According to documentation, this should copy the keystore.

But it seems the keystore SHA1 fingerprint has changed. I’m not sure how this could have happened.
I tried copying the keystore from the original project, but same error is shown in Google Dev.

1 Like


  1. Download the key from the old project and copy the password
  2. Upload and paste the password in the new project
  3. Download the apk
    ** It is recommended to participate in the custody plan
1 Like

Thanks Tony for the suggestion. But I tried that. Ended up with same SHA1 key being mentioned not matching the one being used on Google Play dev.

Is there an easy way to check the SHA1 of the App via thunkable? Like they show on Google Play?

Not sure how this (or I) messed this up. But only solutions right now I can think of is somehow take certificate from Google Play dev and recreate a keystore to use on Thunkable? Or request to change the key on Google Play dev, but they clearly mention this is a onetime thing.

Would be great if this part would get some more details on the documentation/guide.


^ Download from previous apps

^ Upload in the new app