Problem Creating Object in Realtime DB

Hi! I’m not having success creating an object in Realtime DB in the normal way. What I’m trying to create is:

{Service Center
{Address Data}
Maybe there’s something wrong with my blocks:

Realtime DB doesn’t acknowledge anything at all with this configuration. It looks similar to me to examples I’ve seen in videos that worked, and I actually had something like this working a couple weeks ago. But lately, nothing happens at all in the data base with this configuration.

I have been able to get the response I want in Realtime DB with this layout:

It works the way I want, but it seems like a lot of blocks that the other layout should also accomplish. Is there something I’m missing in object creation?

Hi @sr3,

Could you show a snippet of what your Firebase should look like, along with some more information on it. A project link would be awesome.

1 Like

Sorry for the delay. Busy weekend…

Here’s a screenshot of the Realtime DB:

Project link: Thunkable


When the button is clicked, do you update all information under the persons name? Does the user submit all this data at the same time?

I don’t currently have access to a computer to show you a solution done out so apologies on that end. Your first set of blocks using the create object with fields block should work fine, this is how I would potentially achieve something like this. Thunkable Docs have an example of this here.

This post also has some information too:

The only potential issue I can find with your blocks is two users having the same name, but this wasn’t in your request so I wont go there :stuck_out_tongue_closed_eyes:

1 Like

Thanks! Since I’m the only one using this right now, I have made two users, both me, with the same name. :wink:

I have tried using the create object with fields, and that’s when I don’t get a response from the database. Nothing happens. That’s when I looked for another option and did the cumbersome nesting solution. It works that way, so I don’t think the issue is having more than one user with the same name.

The weird thing is that at one point I did get something working with the create object with fields solution. But it quit working and I haven’t been able to figure out why…