One more issue with "number of rows"

In my case I found that “number of raws” block works incorrect if we work with airtable datasource which has more than one table.
In this case number of raws from first table returns correct, and if we choose the second one the variable is empty

Can you post a link to your project?

I prepared case here

1 Like

I can only see one table in your Data section in the development screen. So you will not be able to get the number of rows to a non mapped / linked table even if you start by pressing button 2 first then button 1.


When you try to copy a project with Airtable tables, Thunkable will not copy the keys along with the project and will convert Airtable tables to Local Data Sources (this is a problem and a privacy advantage, you can see it both ways) so either there is a problem in the project linking the tables or a problem with the way Thunkable convert the tables when copying someone else’s project.

I used your project and linked my Airtable samples. a table with 3 records and a table with 2 records


I ran your project and the results were as expected

This is the result.

Yeath, thank you for your respond

The problem was in airtable data source and conversion to thunkable. I created new data source in airtable, connect it to my project and now it works correct