Number or Rows block doesn't increase while inserting data in airtable

I am using the new version of Thunkable X with airtable as a datasource. But I encounter with a problem using the “number of rows” block that it doens’t update the number of rows in airtable. It keeps the number of rows when the app starts.

The screenshot of a simple test, any time I insert a new data into airtable, the number of rows remain the same.


After that i added a data list viewer connected to the same table, the number of rows remain the same meanwhile the data list viewer updates to display the new row. I tried using “list of values in column” block and then get the length but same thing happen.

¿Is this a Bug?

Try adding a wait block after the create. You may not be giving airtable time to create the row before asking for how many rows there are.

Thanks @catsarisky but it doesn’t work, I added a 10 seconds wait with same results, actually I added more than 4 elements, all of them are displayed into Data List Viewer but not in the number of rows.

Check this:


Thanks @isaias.sanchez.lzc - this is a known bug which was discovered at the same time as the create row issue.

Both are being worked on at the moment. We should hopefully be able to test and release these fixes next week.

I just reproduced it. Here’s a link: Thunkable

aaaaand, now I see Dom says they know about it. Bah. :slight_smile:

@domhnallohanlon - maybe related, maybe not, as I’m not sure what the “create row issue” is? I can’t create a row in a google sheet. I’m pulling data from a data viewer list, so I know the sheet permissions are OK for that, but it won’t create a row in the sheet, just hangs forever. Note that this is Google Sheets, not Airtable.

Amazing @domhnallohanlon , I’ll wait for that release.

For the time been I just create a workaround using autoincremental id into airtable and use it as the last row, it’s not accurate when there are deleted rows in between, but it’s doing pretty well in my case.

1 Like