Data viewer: Can't write to airtable, can only read

Create row or Update value blocks for airtable is not working for me. I can only get value from table. Is anyone experiencing same?
Please help.

Yes, even I have experienced the same issue.


That’s my code which isn’t working for me. Is yours somewhere along those lines?

What value does the green “error” block have when you run a CreateRow block?

I just tried creating a new row in an Airtable document using both the Airtable “CreateRow” block and the Data Sources “create row” block and both worked for me.

I’ve had so much frustrations with my projects these days. I have had to abandon an almost finished project and reverted back to old version of thunkableX. Maybe it fails when you create more than one tables. Try adding another table using Data Sources, It doesn’t work. I’ve tried all: deleting, recreating, syncing etc. No success.

Now it’s working for me, after @tatiang helped me with it:
Just add a
if error
from label 1 set text to error
else
rest of the code
inside the then do section of create row.
This worked for me.

Using Data Sources, output(error) is not returned. See image: airtable_error

@Patrick_Elisha Try using the Airtable CreateRow block instead of the Data Sources’ create row block. It has an error block.

Unfortunately airtable is no longer available separate from Data Sources. You still have it because you used it in your project earlier. Is there a way to revert back to the old thunkableX as it appears staff are currently overwhelmed. Even as a Pro user, I no longer get prompt support as before.

You can turn off invisible components from your account settings. That should bring back the Airtable blocks. This all sounds very frustrating!