Createrow in airtable (idk what Im doing wrong here)

The error occurs when creating a row derive from a list data source.

Any idea what I could be doing wrong here?

1 Like

Can you post a screenshot of your Airtable data? The column names need to exactly match (case-sensitive) what you have in your CreateRow block.

Are you able to get values from Airtable in Thunkable?

1 Like

I had double checked the column names. Its a blank table that gets content from a list otherwise. (well as i understand not entirely blank since it needs at least 1 blank row to work…)
If I fail to get this workign Im just going to use data viewer list I guess. Was aiming on buttons.

1 Like

In your if-else statement you only wrote for if there is an error, you can code something in 'else ’
section or delete the ‘else’ section.
Hope this helps,
Kaustubh Maladkar

1 Like

I just tried something similar and it worked, using only the first column name. I know that can potentially cause a problem but I would recommend trying the same thing. In your case, for the rowObject field, create an object with fields “Title” (only) with the value of “Title” set to “Test”.

Does that work? If so, it may be something in the way you’re formatting your joined strings.

1 Like

Tried this. Still no luck so its not the string join. It like it cant find my table at all? Im going to try a new project and do a really straightforward createrow block as a test next.

1 Like

Started a fresh project and a free airtable with a SINGLE field column and still getting same issue.


Any clues?

1 Like

Are you able to get data from Airtable?


Ok I created a Get option and filled in a row in the test table i made. It returns the error “undefined” but the table should not be blank or anything.
Since then I did bypass the issue by using a list with data source instead of buttons and thats working fine. I do not understand why im having so much trouble with the other methods tho.

1 Like

I would try adding a new Airtable component and entering all of your details again, checking them from within Airtable itself. Then do a Get block again to see if you can retrieve values. Until that works, you really can’t move on to updating values or doing more complex things with Airtable.


Thanks a bunch. Something to ponder later I think.

1 Like


That’s the worst. Glad you found it!

Please mark it as solved then