Airtable Create Row Failed

Hi, I tried to create a row using the blocks below:


However no matter how much I tried, the app just crashes. This happens both on Live Test and installed APK. I am very sure that the settings for Airtable is correct as I can perform other actions like GetRow. I am also sure that the 3 variables used to create the object are valid as recorded down by the “ErrorCatcher” block. I am also using my own Airtable account.

Airtable wise, the table is a clean table without any records. However the fields are created and exactly same name as the object property name in Thunkable blocks. Any help will be appreciated, however I’m sorry that I could not provide the original app as it contains sensitive information.

thank you, that’s what I searched here :slight_smile:

What?

Hi there,

Try removing the ‘generate JSON from object’ block in the Create Row block.
The Row Object needs to be an object, not some JSON!

You can see an example of a Create Row block in the Uploading and Updating Data section of the spreadsheet docs.

Hope that helps!

1 Like

Hi, thanks for your suggestion. However the app still crashes. From my Airtable, I can tell that the app crashes right before executing the “CreateRow” command, as the previous blocks were executed successfully (They modify a cell in Airtable, which was indeed modified). I have already followed your suggestion, and also removed the error catcher blocks.

Just to add on, I added back the error catcher and now the error message is “trouble creating row”. Only these 3 words

Thanks @aliencaocao,

Possible to attach a screenshot of the new blocks you are using?

Sure.

Hello there!

I’ve experienced this too!

When I was building a Registration for Conference App, The ap used to popup the user’s unique ID just after clicking the “Register” button… As soon as I pressed the register button, the popup showed for just > 0.5 seconds, & then the app crashed.

The solution I came to was -

  • Check every object title you created using create_object block - every object’s title should match letter-to-letter (it’s cAsE sEnSiTiVe) with the Airtable Column name.
  • browse the whole create_object block, if you are missing any columns.

Do these steps, & check if it helps :wink:
Thanks a lot! :smile:

Thanks for your reply, however I am aware of such precautions and have checked carefully those titles against the column name. I ensured that they matches by directly copying and pasting those text from airtable to thunkable. Still no luck.

If you have a problem with AirTable, do step by step debugging.

  1. First make sure that the row is added to the table
  2. If the row is in the table, but you cannot get it in the application, then an error occurred while retrieving data from the table.
1 Like

As I said earlier in my post, the row never gets added, and therefore im very sure that it crashes right before submitting the row to Airtable. The error message “trouble creating row” also proves that.

Update:
I solved the issue by creating another airtable component that contains my second spreadsheet’s table name and view name. It seems that the issue is with the change table name/view name blocks, where it cannot successfully change before I submit a new row, resulting row creating failed as it submitted to the wrong spreadsheet with different column headings.
I personally think its a thunkable issue, so please look into that.
Thanks!

3 Likes