After recent changes in airtable I can't find row number anymore

Ok so, thye just changed airtable, now when you create a new row you “upload” it as an object, no problem there, BUT,

I’m not able to retrieve the row number of the row but only the rowID, and I need the rowNum to work with airtable component

gives back the entire row as an object and not the row number.

I also tried datasources but they don’t work at all.

Why did you decide that this block should return the line number? This block correctly returns the entire row, and to search for its number, you need to create a loop over all the rows and check for id matches.

But why do you need to know the row number?

Cause it did use to return the row number and I need the row number to edit the info contained in that row, how can I address a specific cell otherwise?

there is no id in the row result

To access a cell, there are blocks that do not require a line number.

and how do you know what cell are you accessing?


You need the row number.

set cell

Yes, but can you show what the row block returns?It returns the _id?

I think it gives back the id, I just realized it does, but I need the number, cause airtable component works with rowNum, while datasources component work with rowID

You need to create a loop over all the rows and check for _id matches. Use изображение

I solved in another way, but it used to give the row number as a result of adding a new row.

I think they are changing stuff to make data sources work better or something like that.

Thanks for your time, you helped me clarify few things that I didn’t really get as I had the rowID reasult as a list so I didn’t realize atm

hello, i’m having trouble finding the row number, it worked perfectly this week now it doesn’t work anymore. if they are changing anything in the database, I think Thunkable should report the situation. because I added new content to my app and now the new update doesn’t work because it can’t find the row number

1 Like

Can you clarify what doesn’t work?

  1. Why do you use LocalDB if you can use stored blocks?

  2. After selecting the list item, what is in the stored.noticia block?

  3. when the s.starts screen starts, is Admob displayed? If displayed, what is in the stored.noticia block?

  4. Are you sure that stored. noticia contains a number and not a number in string form? If a numeric literal is set in AirTable2.GetCell, the data is loaded from the cell?

You know that Thunkable X is updated regularly. And once something is updated, there is a chance that something in the new update might work differently.

  1. stored news contains the selected item number
  2. admob shows well, and in the news actors is the item number (which should be the row number)
  3. which should send the link corresponding to the item to the web viewer. but now it calls an unmatched row. I remember it used to work

admob shows well, and in the news actors is the item number (which should be the row number)

I see a problem in this phrase. You write that the variable block should be the row number. One of the main rules of the developer is that the developer must be sure of what is in his block. Any suggestion of what might be there is a gross error and unreliable development. For this reason, I will repeat my question: what is in the stored block before using it in the AirTable block?

is the index of the selected item in the list viewer. which will then be used to call the airtable row number

i had to do over my published app because of this use the do something component

1 Like

see this

@Fernando, to search for errors, you need to DISPLAY the values of ALL blocks sequentially.

Tell me, how do you want to find the error? Do you think that you can find the error if you look at the blocks for a long time and think about where it might be? But this way you can look at them all day and even for a week. I offer you a simple way - display the values of all blocks on the screen. If you think that this is very difficult and you don’t want to waste time on it, then you can give a link to your project with access keys to AirTable and ask someone to do this work for you. If someone knows other ways to find errors, then tell me about it.