NSUserTrackingUsageDescription preventing updating of APP in AppConnect (iOS)

I’ve read through the multitude of similar posts but have been unable to resolve. Basic info:
My app uses web viewer and location. It does NOT include and advertisements (e.g. AdMob). It collects e-mail address and device type. Such information is for app functionality and not shared with any 3rd party. The field for “Tracking Usage Description” is empty both in the App Settings and when publishing (checked and rechecked, both were empty before republishing).

After discussing with Apple, the issue is my selection of “Other Data”. I was told that since i do not share the info, i should select “NO” for the question on app tracking. When I do select NO in the Privacy “Other” section, as shown below, i am not able to proceed:

Is there some other place in either my APP on Thunkable or on the App Connect side that I need to undeclare the tracking for “Other” data? I can’t tell why AppConnect is generating the message, although they mention the “app binary”, so i can’t correct it.

Hi @KaneoheKid, thanks for flagging this issue. This can be a complicated process for sure.

In this particular case, since you are using a web viewer and a location sensor, you do need to disclose that you are using other data types for tracking purposes and fill out your Tracking Usage Description. That description is located in two places: the first is in the project settings:
image
and then also during the publishing process in the Publishing Wizard:

For the web viewer we suggest you add the following to your Tracking Usage Description:
“This app accesses [name and URL] website. Your data may be shared with this website to facilitate functionality.”

For the location sensor, you would add:
“This app also uses your location to show you information relevant to your area.”

Adding both of those statements and changing your indication of using other data types to Yes, you should be good to go. Because this Tracking Description is packaged in your build, you will need to start that process over again with a new build.

Here is an article with all of the information I added previously.

Please feel free to reach out if you do run into any other issues or have any other questions.

Thanks, i actually had that in the Usage Description fields but removed it when Apple said it wasn’t needed. However, i went ahead and put it back for the next submission (actual language is, “This app accesses Google Map and Firebase database websites. Your data may be shared with this website to facilitate functionality.”) as attached.


I changed all my tracking responses to YES.


However, I still get rejected. When i run the app with Thinkable Live on a clean iPad, there is no popup when the app loads, as is described in the rejection notice.

Shouldn’t the statement in the Tracking Usage Description be popping up the first time the app runs in both Thinkable Live and also the binary? Is there anything which would cause the pop-up not to trigger the first time the app is opened?