"Make Copy" quit working in Thunkable X

The last time a tried to make a copy of my program a couple of months ago it worked fine. Now the “Make Copy” button does nothing. I also found a new “Duplicate” button that does nothing. I have cleared my browsing data but no change. Using Google Chrome in Windows 10. Any help would be appreciated.

I have same problem

Hi there,

Can you share the URL of a project that demonstrates this behavior?

This is my project that does not copy: Thunkable
I did test a simple program and “Make Copy” worked ok. Thanks.

I thought this had happened to me, too, but it turned out that a copy was being made each time but with the original file’s creation date as the “date modified” value. Try searching for the project by name.

1 Like

Thanks for sharing!
We are aware of the behavior Tatian reported in a reply here.

My understanding is that if you Make a Copy of a snap-to-place project, everything works as expected.

If you try to Duplicate a Drag and Drop project, the Last Updated date will not be the current date/time, so you won’t see your project at the top of your project list. However, if you search for this project by name, you will find it.

Does this align with what you are experiencing?


Hi @jane, this isn’t how it is for me. I had a snap to place project which I tried to duplicate, but I didn’t find it at the top. I duplicated twice more, but still didn’t see it. Then I came across this thread and search for it by name and found it, dated December 9th 2020 (the original creation date of that project). So this behavior is the same for even StP projects.

1 Like

Yes, I did find a bunch of copies that were stored back on the original start date as CodeSwept indicated.
Hopefully this can be fixed soon.
Thanks for everyone’s help,

1 Like

For me, StP is showing the copied project on top of the list with current date not original creation date.

1 Like

Hi again,

This behavior seems to be resolved. Can you try copying a Drag and Drop Project, and a Snap to Place project, and see if:

  • You see the Copy Made! pop-up
  • You see the copied project in your projects list with the correct date


1 Like

I do not know how to use the Drag and Drop or Snap to Place that you talk about?
I do not see the “Copy Made” that I used to see when I pushed “Make Copy”.
I can find the copies when I “filter by project name”. (The copy used to be at the top of the list when I opened Thunkable.)

I tried a hard refresh in Chrome and used the Duplicate command from the projects page to duplicate a Snap to Place project called “Photo Journal 2.4 APP STORES”. There was no notification and a copy was not made.

I then tried to duplicate an older Snap to Place project and it worked. It created a copy, notified me when it was done copying and set the modified date to today.