"Aw snap" error in Chrome browser when duplicating or copying projects

Using a Windows 10 PC with Chrome browser, I am unable to duplicate or copy projects to make backups. I am using only half of the Thunkable data storage allowance and have 100Mb left. The project I want to duplicate is 4Mb in size. Tried logging out and back in, but that did not help. Tried another Browser (Firefox), same problem.


I have an update on this.

I discovered that each new attempt to copy/duplicate was causing my storage-used figure to rise. So, what’s happening is that the projects are in fact being copied/duplicated but they are appearing way down the list of projects with an incorrect date/time stamp.

An improvement but still not ideal.

Usually aw snap errors are there when a page is KILLED. Try checking the browser task manager after/before you duplicate the project…And lastly why do you want to copy/share/duplicate a project? And where do you wanna put it?

Also clear the browser cashe

Have you ever noticed that behaviour before @penny?

Just wondering if you’ve tried using our new project search bar?

No, this is an entirely new thing. Copying/duplicating used to be routine. Time-stamped appropriately and placed at the top of a reverse-chronologically ordered list of projects.

Well, I tried several browsers and the behavior endured across all. The reason for copying/duplicating is to provide a backup in case my latest tweaks turn bad.

The page must have crashed because copying or duplicating such projects must be some prob