Local table bugged since yesterday?

Hello thunkers.
Without making any change to my blocks that will have some influence on local tables, since yesterday my app starts to freeze when it comes to work with these.
First, i thought that Firebase is the issue, but i tested…

On this fragment of my app, i put some testing blocks to see where app freezes. App is accesing Firebase, it shows "TEST_01"message as expected, but "TEST_02 it doesnt show, app stops on the way. If it was some error on deleting, i have IF to show that tho, but no error appears also. Not asyncronous issue also (as i told you, all worked just fine since yesterday, i added just testing blocks on my blocks to see where app is freezeing, showing only a loading icon).
Anyone else have problems working with local tables lately ?
Thank you.

P.S. this is a simple test for local tables… My App freeze whatever other action will take using local tables. (im using mobile preview app). If i run installed .apk that i downloaded few days ago, all works fine.


I have the same problem as you.
How can this be fixed?

The create row block is bugged. Actual firebase cloud variables seem to be working fine, but if you are putting your firebase data into a local table, that’s probably your problem.

I’m hoping we get a swift reply (and fix!) from @Thunkable_Staff on this because it’s a bad one!


Well, thank you for your response, but for me delete row is not working also, and affects Thunkable live :thinking:
Im really stucked on my development so im waiting for a fix from @Thunkable_Staff too :slight_smile:

That might be a separate issue. If you have a simple project that shows the behavior, I hope you’ll post a bug report!

just made a simple app to test again local table usage
im a beginner here, i dont know what else i can do to exemplify bug :thinking:

I simplified it further, to this:

I wanted to take out the “create row” block, because that definitely has issues.

This hang behavior happens on iOS Thunkable Live. Is it the same bug as the one I linked above? I don’t know - but the fact that it happens on Live (while the one above does not) makes me wonder if not.

1 Like

I have the same issue!

For me Live works, but downloaded apps don’t.


1 Like

thank you @catsarisky … delete all rows and create row doesnt work for me, tested multiple times on Android 10 Live Preview. Downloaded .apk is not working for me also.

Thanks mimostel. Would you mind testing this very simple version of the project on Android 10, just to make sure? I always like to provide the developers as simple of a broken project as possible to debug with!

I’m suspicious that there are two (related) bugs, given that one of them isn’t present on Live and the other one is. Let’s make sure the developers fix BOTH, huh?

Here’s the project link: Thunkable

I’ll add your results to the bug report if so. Many thanks!

i just did… pressing button doesnt change that label (as it supposed to do).

Ok. Adding Android 10 Live to the report.

iOS 14.6, Thunkable version 276

Live: Doesn’t work

Downloaded: Doesn’t work

1 Like

@skulamester Wait - what? Live is broken for me and I’m on iOS 14.5.

You are right! I updated the Thunkable Live from App Store and now version 276 doesn’t work, the version before (271) worked.

ohhh… interesting.

Confirmed. Same behavior here…

1 Like

I made more tests on the delete block. It works for the first time only and then it stops.

Every time I run the app from the Live app it deletes the records the first time but any subsequent actions to delete all rows does not work anymore.

android Thunkable Live v.279 is on PlayStore. Problem was solved for me. :heart_eyes: :clap: Thank you @Thunkable_Staff