[Solve] How do I save a row to a local table?

I am new to Thunkable, so I need to ask.
Sometimes when I am working I try things out and then suddenly the app crashes. That’s fine, I understand it’s because of my bad coding :grin:

But then I reconstruct the app to how it was before I messed around and still it crashes.

That happened to me yesterday, and I never got it working again, then today I got to my office to see if it still crashes and it’s not! I have been able to work a bit, but now it has crashed again. And I am sure I have recunstruct the app to how it was when I started this morning. (I took a screenshot) :blush:

Is there any way to see what’s causing this? Is it a bug or bad coding? I mean, I haven’t done anything…as I went back to how it was this morning when it worked…

This is my screenshot from this morning:

This is a screenshot of how it looks now:

I don’t see any different, do you?

I have only worked with the blocks underneath the “set List_Viewer1’stext items to app variable tempList”.
So, basically 2 blocks at the end…

I do make copies for my projects but that’s when I have managed to get 1 or more step further in production. Which I did not this morning so no copies are made today. =)

Thanks for any help…

To add: The app works fine in my IOS iPhone…
So it seam to be only in the web-platform and simulator… on desktop(?)

wanted to share:
Logout and Login again seemed to work for me…

It looks like you are trying to insert an entire row into a list. That’ll make the app crash.

Hi, thanks for your reply. Yes that’s correct, that was for testing. I have updated it to this now and now it works :blush:


Hi guys.
I still got this issue with crashing app actually.
So, I do have a function which kicks in when screen is starting, I wanted to make some changes in that function, but suddenly the app crashed. So I tried to rebuild the function to how it was, but it still crashes. Then I tried to remove that function completely from the Screen1Starts-block, but still the app is crashing.

It is only in the “Live Test” feature inside the Thunkable web platform (The simulator) that this is happening. When looking through my iPhone and the Thunkable live app it works fine.

Why is this happening? Is there any “tricks” / workarounds for this or is it simply better to try your code on the iPhone?

Can it be something within my code that causes this? Should I worry? Is there any way to see warnings (if you got any) and logs for your code in Thunkable?

Can anyone see, is there anything weird going on in my code here?

It should just simply filter all items from my Airtable-table to view only the ones belonging to the logged in user in my listViewer.

I am wondering cause often the app crashes and I spend much time to try figure out what is causing this, and then suddenly it works, and then not… and so on…
I did something so simple like move the:

and then put it back again and it worked…

is it something in Thunkable or is it something in my code that makes this happening?

As described earlier I have noticed that the “live test”-feature crashes more often then the mobile-app so that’s just scary to use now. But then sometimes the mobile app gives me messages like “you need to check your blocks”, and then I do something like described above, move something out from the block then put it back again, and it works.

I have not much going on in my app but if there was it would be a pain to “reconnect” all the blocks ever now and then.

This makes me thinking it has to do with my code somehow? Or do I need to update something or do anything else?

Thanks for any help!

I just wanted to answer my self, I figured out what was the issue here. The local table data source was some how corrupt. I deleted that and made a new one and now I haven’t had this problem for a while (do I dare to say to much?) :grimacing:

Anyway, just wanted to share