Fetching data from multiple sources

anyone else having trouble with their list viewer… mine seems to be crashing since last update…

Hi @rojroj101s - can you give us a little more detail than this please? I was using the Data Viewer List yesterday, connected to Google Sheets, and eveything worked fine for me.

Hey @Domhnallohanlon,
It seems if I run this function twice it crashes. This is the function that cant seem to work properly. Strangely it works the first time but if the function is used again it crashes…

I should mention It uses the Local DB

sorry @rojroj101s - the only data viewer I can see is at the very end, when you navigate to the ScoreKeeper screen?

So when I use this function it works fine the first time, It navigates to the data viewer and I can see my info… But if this function runs again, before it can navigate to scorekeeper it crashes and I get the thunkable beaver on my screen.

Ok, I’m moving this to it’s own topic, since it seems the error is happening in your blocks somewhere before the data viewer list is opened.

Starting at the top this is what seems to be happening:

  1. Get Row #10 from Airtable
  2. Add a new row to the LocalDB, with an image and two strings (have you tried checking to see if the get property blocks are returning the correct values?)
  3. Store the RowID of the new row in the LocalDB
  4. Repeat steps 1-3 for Row 11 of your Airtable

Yeah. I did all that. It does work the first time, but when I ask the same DB to add more rows again it crashes… I think the LocalDB might be corrupt.

Your specific LocalDB (i.e. “Home Finalized DB”) or the component in general?

The component in general… Because it does the same thing with the away side… This was all working fine… I have the APK from when it was working… but now its not… its seems its crashing if this componant is being used twice…?

You could maybe test this… If you create a row in LocalDB…Let that action finish… Then later in your app create another row in that LocalDB… My guess is, it will crash…

Are you updating the data source from a screen where the Data Viewer component linked to the source is not visible? If so, this is a known issue and I have a fix which we are currently testing and hope to release within the next day or so. I apologize for the inconvenience! We’re working on getting this out ASAP.

If this isn’t the case, I can take a look if you want to share your project with me (DM is fine) to see if we can determine what the issue might be.

1 Like

yes this sounds like it could be my situation. I’m updating a data source that is in another screen and it not visible until I navigate to that screen and make it visible.

1 Like