Live test crash on one of my projects
This is one of my projects. The thunkable app crashes every time after the live test goes through screen1 no matter how I change the code, but it seems to be fine when I test my other project.Can anyone help?

To find the error, use the adb debugger and send the error log here. If you do not know how to use adb, then to find the error you will have to spend a lot of time and effort. Look in the official documentation and the project possible bugs when running on Android. After that, disconnect the problem blocks. If it does not work, then step-by-step debugging your application - disconnect all indoor units on all screens and connect them one by one. If the application fails, there is a problem with this block.

If everything worked before and now does not work, then remember which components and blocks you added recently - they contain a bug and are contained.

So if you made a copy of the app and you did not change the name correctly that is what caused the problem. Changed the name of my copied app by using my mouse course trying to select the text. But you should only change the name of the app by placing the courser in the text box and backspacing or deleting the text with the keyboard. I know it sounds dumb, but for who ever did what I did will know what I mean. For some reason the app just kept on crashing. Then I tried to reenact it. And then I saw a weird link in the title part of the app. So I deleted it all. But since these are practically web apps, that location URL must stay unchanged. You can change the name of the app if you do as I said before.

And now it is doing the same thing if I made a copy of the app and change any two things. Like it just crashes if I change more than one thing from the original copy. Yikes this is more than a small issue. I just did it a few times with blank copy apps. This is no good!!!

Now I cant even edit the original version I created. What a mess!!!


I’m having some trouble following your description of the steps you took which caused the problem. Any chance that you could provide some screenshots demonstrating what you’re referring to in your description?

Thanks in advance.