Crashes on launch screen

Hi - this appears to be similar to the issue I posted about earlier, but it is different.

Using the Thunkable app to test, the app crashes right away when launched.

The issue before was “Space Evenly”, I ended up having to switch to “Space Around”. Not sure what the problem is as I don’t think I’m using either of these.

Here is a link to my prototype. It does nothing, there is no code, this was merely to test screen layout.

Hi there-

You are right. There seems to be a problem. I just filed a bug and one of our engineers is looking into it.

Thanks for reporting.

Any feedback from the team? I still can’t test my app :sob:

I’ve just deleted a bunch of code. My app is now a screen with a button that takes you to the next screen … it can’t even do this.

Hi @Clayton_Brown -

I just tried it on both Android and iOS and the problem seems to be solved now.

Could you try testing this on a different phone? Also, can you let me know what phone and what version of android you are using?


On my iOS 10.3.3 and the Android 7.1 emulator, the application by reference works without problems.

I’ve tried uninstalling the app and reinstalling it, still doesn’t work. It crashes immediately. I’m on Galaxy Note 5, Android 7.0.

Try using the adb debugger to find out the cause of the application crash.

What is the ADB debugger?

Command line (get logs):

adb logcat > log.txt

ok I’ll try to figure that out.

FYI - just installed the app on my tablet and it does the exact same thing.

Galaxy Note Pro
Android 5.1.1

Also, I’m referring to Thunkable Live, are other folks referring to Thunkable Classic? Seems like regardless of what device I use I get this error. Looking at recent reviews on the app store, looks like others have the same issue.

Can you give me a link to the FYI application that does not work for you? I’ll try to see it on my tablet.

The problem seems to be on the stack navigator component for android. It seems to work just fine on ios. At least, that worked for me.


I started testing on iPhones and iPad last few days. Firstt few tests went fine on both devices wiith Thunkable Live. But after I changed my google password, Thunkable Live keeps crashing at Launch screen.At first I thought it was a bug in my Project, so I loaded and did Live Test with the sample Apps such as Translator and Feelings. Works OK on the iPhone, but not on the iPad. Same crashing.

I even Restore my iPad to factory setting and redownload the Live app. Same problem.
I even created a new and different Apple ID to download a fresh Live app, same, exactly same result. So its not a project problem.

I notice Thunkable Live crahes at launch, so it has not even reached the Log-In screen. It must have been the password chage on the Google account. but how do I chage the password if the Thunkable Live App does not even reach the Log-in Screen?