Issue with upgrading from a previous installed version of an app

I created an apk Android build (version 28) and downloaded it to my phone. This version worked on Web Viewer.
I launched the app and it stopped on a block that clears a table. All tables used by the app are cleared in a series of blocks and I had just copied a previous one, changed the table being cleared and built the app.
I deleted the offending block and recreated it again as there are random issues with builds and moving or deleting a block and reinserting it again (on every screen) seems to fix it. I also opened and closed the table.
However, having created the apk for Build 29, it failed again at the block that clears a newly added table.
I then tried uninstalling the app completely from my phone, and installing Build 29 again, and this worked.
It seems that there may be a problem when an app is upgraded from one installed build to another.

While the Build 29 apk worked on my phone, Build 30 (created for iOS) is hanging on my iPhone.

Hey @finbarr.mccarthytl32
Could you please share a screenshot of the blocks that are crashing the app?

The block that was failing is ‘delete all rows in Text_01 in Table 5’
A couple of builds back, the same thing happened on the block ‘delete all rows in Text_01 in Table 4’.

Hello @finbarr.mccarthytl32
Thank you for sharing the screenshot.
Have you tried to set the error Block into a label?
What was the error?

Hi Ioannis,

As you can see from the blocks in the screenshot, clearing all rows in Table 5 is identical except for the label change and table change to the block that clears all rows in Table 4.
The way I got around the problem was to delete the block 'delete all rows in Table 5, and pasting it back in again (i.e. no change to the block except the cut and paste).
However, it was unexpected behaviour and completely random - blocks on other screens had changed, so I don’t understand why this block failed on this screen before I cut and pasted it.

Hello @finbarr.mccarthytl32!
Is it possible that you added these blocks and then made a change to the structure of the Table?
Did you change for example the Table name or the type (App/Stored)?

Hi Ioannis,
Table 5 was added.
Then the blocks to delete all rows in Table 5 were added.
It worked on Web Viewer, but failed on Android and iOS.
I cut and pasted the blocks back in again. It worked on Web Viewer and worked on Android and iOS.