Is the beaver sick?

Hey ! Is it possible that the beaver badly compiles my app ? Because it’s been 3h I’ve been compiling and recompiling, and what works on Thunkable Live doesn’t work on my installed app (basically just an if condition). Thanks !

Do I have to wait until like tomorrow and compile again or do I have to worry about the whole app ?

Thank you !


Can you give me a little bit detail about the problem? Did your build/publish fail? If so, can you give me the reference id in the email?


It didn’t fail, but when i opened my app on my phone, the blocks that were working on my live test failed to work :confused:

These blocks work perfectly on thunkable live but fail to work on my iPhone once installed. Please note all the firebase components, keys and values have been re-entered and checked and are all correct.

Note : As I know my app, I can tell you that when the app is installed, the blocks won’t execute after the set namee to value, yet namee is being set to value (checked with a label) :confused:

Thanks for helping @wei !

Hey @wei & @Mark, any news on that ?

Update : I tried changing the app bundle iD but still.

Update 2 : re-rechecked all the blocks and they are all doing what they should be doing :confused:

Thanks for helping ! :slight_smile:

Please take another look at my post at What should I put when no value is found which talks about how to check for errors and when to use the “null” string. I can see a number of cases in the screenshot above where you are doing things differently than in my post. There’s no guarantee that that will fix your problem, but at least we can then rule that out.


Actually, all the advices you’ve given me have been respected in this project and that’s what made it work ! I was told to use the green null block for RealtimeDB and the null string for local storage.

But anyway, the app is working fine on my livetest, and “stops” working after I install it, I used the tutorial you made on Asynch loops, and your advices on the null blocks/strings.

That was not my advice. Please read my post again. Also, I see at least one instance of your app checking for the green null block in a Local Storage block. Finally, I also see that in your RealtimeDB block you set ‘namee’ before checking for an error. That’s probably not advisable.

There can sometimes be differences between live test behavior and installed apps behavior. BTW, are you live testing and installing on the same phone?


This was fixed, my bad :frowning: (Doesn’t work either)

I am showing the given value on a label, that counts for an error check no ? :confused:

Yes, I tried on multiple phones and doesn’t change anything :confused:

Thanks for helping @Mark

How may I fix it ? Thanks :slight_smile: !

Hey @Mark and @wei, after two days without working on my project I come back today, install it and it worked. That’s very strange but ill do with it. Thank for your help !

1 Like