iOS Permission for Push Notifications

Hi Thunkers,

My iOS app requests the users to allow the App to send push notifications at first open. Is there any way to ask for this permission in a different screen?

Has anyone been able to do that?

As far as I know, however this is based on my experience of publishing apps with push notifications, the user will be prompt to enable/disable push notifications on first launch. They can choose to accept or decline, and this can only be further changed in settings. I believe this may be a thing with Apple as I am yet to see another application do this, however you can open a deep link “url” (path) to the app config in iOS settings with Thunkable.

That’s right. Thanks!

Hovewer, I think it’s really important for users to get a sense of the App before to decide whether or not allow the push notifications. I think it’s not right to ask for it earlier than the onboarding, for instance.

Do you mean that I need to contact Apple to modify this?

Yes you may have a point here, though I wouldn’t consider it a deal breaker imop. Apple do not have any way of alerting this. All of this works around how you build the app.

Indeed, this is what I thought - we need to fix this in our Apps.

So, is there any possibility we can postpone this permission request? If so, how can we do that?

Not right now. I’ve downloaded plenty of apps with a similar alert at first startup to ask for notifications or location. I don’t think this should be a problem for your app, however I understand you do not want this.

Thank you for your response.

Instead, I think this is a very important issue to fix.

I hope the Thunkable team would be able to provide a timeline for this, if possible.

Thank you for the above @drted.

Does this procedure disable the permission that appears for push notifications at startup of the App? I don’t think so, because there isn’t anything that doesn’t trigger this permission.

In order to be clearer: at current stage a user download and opens the App - first thing he sees it’s the permission for push notification. Following your procedure, how we can prevent the permission for push notification to appear at startup?

Sorry, I misunderstood your question. My bad (suggestion deleted…) :grimacing: