iOS (13.5.1) downloaded app doesn't open in iOS (but works fine in Android)

Hi everyone,

Opening this app I just get the beaver’s face for a second and the the screen goes blank, then nothing.

I’m remixing this app and there’s one screen which I decided to leave out. But I did not delete it because I thought I might go back to it at some stage…AND I thought I might delete something to cause an error.

But it works fine in Android. Is Apple fussy about a dormant screen being there?

Anyway, I have tried deleting older versions of the app and I have tried replacing its logo image…but this has not helped. I also incremented the app version number…nothing.

Can anyone suggest any other approaches?

Hey @penny, can you tell us a bit more what you mean by a “dormant screen”? I don’t think this should be an issue, but perhaps you can share a screenshot of your component tree with us?

Was there something “wrong” with the original app icon from the project you remixed? What image format is your icon?

This is often the cause of crashes - thanks for ruling this out for us!

By ‘dormant’, I mean that there is a screen there with components and blocks which are being skipped over and by-passed. All the links into and out of that screen have been changed to link to other screens. However, the components of the screen remain there and are unused at this time. Better to delete the whole screen?

The icon idea was something someone mentioned somewhere. I just replaced it to be sure it wasn’t causing trouble.

Hey guys,

I am having the same problem with my app, it works great on the old live v198 on my iPad but crushes on the new one. When I download it it works till the page that has location sensor and crashed with a white screen. I really need help.

What can I do?

Hey @thanos-x - thanks for getting in touch.

We have two separate topics open where you can keep track of both parts of your question.

For issues about Thunkable Live see here:

Note: We’re currently waiting on Apple to review the iOS app.

I think this could be an issue with your blocks. Please take a look at this topic first and if you think it’s a different issue too (which I suspect it is) please open a new topic.


I have figured it out it seems to be an issue with the map component once i deleted it on one page it only crashes on the pages where the maps are, so once i deleted it on all pages it loads all the way with no crashes (NB: theis was working before great). Which begs the questions, What’s up with maps now ???

Got it - thankfully we’re working on this already…I just haven’t had a chance to consolidate the Community posts about the Map component yet. (The Engineers move faster than I do! :joy: )


Hello @domhnallohanlon
I think I got a simmelar problem, if i preview my app in thunkable live everythink is working fine. if I download the App for IOS and open the app, it shows a white screen.

this may be caused by the map component on the start screen?

THX for any reply!!

I don’t have any map component and I have the same issue this is a thunkable bug

My App do not have Map component. It’s using Firebase and Local Storage.
I have an App working well under iOS Live App.
It worked on iPhone and iPad when I download iOS App via email.

I have the same problem of blank screen when published into Apple Developer Portal.

FYI, this app is working well in Android and PlayStore (published).

Hope someone can give me pointer where the problem is.

i thought this issue was fixed i was able to update my app

It was a .gif and I overcame the problem by switching it out for a .png file of the same. Maybe .gif images are problematic the same way .m4a sound files are (.mp3 seems a safer option).