[In Progress] Data Source Google Sheets down?

Hey all,

Very new to the Thunkable world and so far it has been awesome. Very excited about the endless possibilities here.

Something I noticed last night and this morning - when adding a data source from Google Sheets, Thunkable no longer loads the pop-up that allows me to choose the spreadsheet I want to source. The data source window loads, but the “select a sheet” button does no action. It was working great yesterday morning! I’ve tried various things such as switching browsers, clearing cookies and cache, but to no avail. Any insight is greatly appreciated!!

All the best,


Hey @joe.s30 - glad to hear your first few days have been positive!

It’s possible that Google themselves might be responsible for this one? (I just can’t say for certain from that screenshot!)

Can you check your browser to make sure that pop-ups aren’t being blocked please?



Hey @domhnallohanlon thanks for the reply. I have confirmed pop ups are not being blocked. Currently using Chrome, and when using Safari I have the same issue.

Here is a quick video to illustrate better.

I appreciate all the help!!


1 Like

Thanks @joe.s30…that’s odd!

Can you go to https://myaccount.google.com/permissions and disconnect Thunkable, then go through the Auth process again.

That should do the trick.

1 Like

I’m glad you think it’s odd as well :smile:

I’ve gone ahead and removed all Thunkable permissions, and unfortunately still am running into the same thing. Could it be something local/unique to my machine?

Thank you!


Did you have to sign in/authenticate again after you removed it?

Just to sign in to my account, but never got to the app permissions pop-up for Thunkable to access sheets.

In looking at the google permissions page in my account I can see Thunkable is allowed to sign in, but not listed as a third party app with access.



Just out of curiosity can you try creating a new project, add a Dataviewer and see if that works for you?


1 Like


Alas, no dice. I also tried the new project on a windows machine, just to try, and have the same issue.

Maybe something with my account?

Thanks again for all the help!!


No worries…I’ve only seen this happen once, and that was to my own account! :sob:

I’m going to let one of our engineers know about this and get back to you when I hear more.

Can you tell me a little more about the app you’re trying to build and can you send me your project link too please? Feel free to send that by PM if you’d prefer!

1 Like

I have the same problem!

1 Like

Hey @Balanced_Kitchen glad I’m not alone! :laughing:

I created an entirely new google and thunkable account. I was able to access a file in the googledrive but only if it was created there. Most likely our current problem is with the accounts but I don’t know how we can solve it. I hope someone helps us!

I have the same problem with airtable and google. Something is up with the app UI. It just shows a white browser page.

If you know what a VPN is, you can try this method to log in to your account from Thunkable. I have not tried this method and offer it as another option for those who understand what it is.

@Balanced_Kitchen @exploriverse.com can you try removing Thunkable from your Google account and then try going through the authentication process again:


Thanks @domhnallohanlon @actech for the suggestion, but the problem remains. I experimented with everything that would help. VPN, cache cleanup, other browser.

On the forum, I took a screenshot of the browser console that displays this error. Can you give screenshot of console?

As a temporary workaround, you can publish your document and then get it using a GET request in JSON format. After that, write the received data to the DataSource and display it. This sounds sad, but at least you can display the data. I haven’t had any experience with the REST API, so I won’t say anything about this topic.

Hi, I’m a new member of thunkable community…I have a problem similar …when I clik on a google sheet in the data sources, is impossible to see the data and it shows this message: GraphQL error: There was a problem fetching the data, please check your input and try again. Thanks for help!

Ps: i saw many tutorial of classic thunkable and it was simple to connet google sheet; why the new thunkable x doesn’t have google sheet component? It’s very important to me to be able to connect the new app with google sheet! thank a lot for your help