How to show picture from database in thunkable

I am making an app in which I am showing profile picture of the person which I am retrieving from database into the image component through code which worked well for whole day but now not displaying in my app. The code I used is mentioned below. Kindly guide me with appropriate solution.


The image of my database is a follows:-

What is the text string value of Image18's Picture when you run that code?

Also, it looks like you’re using the variable NEW_PIC before you set it’s value. But it’s hard to tell from the screenshots. In the two screenshots above, which one runs first in your code? I assume it’s the when Profile Opens block.

First when the person signs in i save the link of the image in the variable new_pic from database. Then in the profile page I display the value of the same in the image19 component.

Right but what I’m asking is… did you check to make sure the value of Image18’s Picture is what you think it should be?

Right below the circled block in the second screenshot, add a block that says:

set label's text to app variable NEW_PIC

Then when you preview the project, what is the value of that label? Is it what you expect it to be?

Also, where are you storing these pictures? Because it looks like you’re storing them on a local hard drive (file:///) which isn’t going to work with a cloud-based database like Firebase. You need to store them in the cloud.

1 Like

Yes, I am storing it in cloud and calling that link here. however, it works occasionally not always.

1 Like

If your image URL starts with file:/// then this is a local file saved in your device and the image will show only if you run the app from the same device that has the image file.

Remember, the cloud is having the URL which is a pointer to where the file actually exists.

To be able to view if from any device, the image has to be first uploaded to a cloud storage and the URL of that storage is saved to RTDB.

1 Like

for that later on I used cloudinary , but still occasionally vanishes.

I don’t know what that means. If you are using Cloudinary, then you will have a Cloudinary url. Share that and a screenshot of whatever is still not working.

It started working. was slow a little bit but worked well later on. Thanks