Google sheet not updating

Hi all.
I am using google sheets in My project.
However whenever i update a value e.g. dark mode: On/Off the value does not update and the screen stays in dark/light mode depending on the users setting.
How do i solve this?
P.s. When refreshing the app it does update.


Please provide screenshots of your blocks and of the effect your are describing. We can’t easily guess about what’s causing it…

1 Like

When i click the button it updates the sheet but in the app it stays the same value it was before clicking the button

1 Like

It sounds like the problem you’re having is that you have an updated value in a Google Sheet but when you check a condition to see if the value = ONWAAR, it doesn’t return true.

I would need to see more of your blocks to know how to help you. Can you simplify things and just check for an existing value in Google Sheet and see if you can get the condition to return true? I get that you’re trying to change to dark mode but dark mode has nothing to do with this problem. It’s just how you happen to be using the values in your project. It could just as easily be called “tomato”… what we care about is the Google Sheet value and whether or not it’s triggering your if/then condition.

What happens if you do `if → get value from user data = ONWAAR → set label’s value to “TRUE”?


There is a bug with the get value block. It will get the value only once and then will read from cache.

Use the get row block instead and you will see the updated values.


Has this been filed on Github?


I don’t think so. It was reported by a member and @jane worked on it and fixed it at that time. I tested it myself. But for some reason it came back again. I noticed it because this is the second issue raised these couple of weeks for the same update issue.

See this post

This is a long standing issue but see my comments in the last few posts


Thanks @muneer that works.
However it’s really slow.

1 Like

That is odd. You can use list of values .... instead. I checked it and it works. It can see updated values. This will work of course in two cases:

  • You are updating one single column
  • The number of rows is not too much.
1 Like

Yeah may be caused by the update block.
It only happens when switching themes in the settings screen, in other screens it just loads correctly.
(unless it’s a image)

1 Like


I am using Thunkable to create an embedded WebApp.

I have made two separate versions of the app (Desktop layout and Mobile layout). Both these are hosted on my Wix site.

The Desktop version is updating Sheets as it should.
However even though the mobile one has the same blocks, it is not updating the spreadsheet.
I have deleted and reconnected the Datasource which hasn’t resolved the issue.

Screenshot of blocks below.

Screen Shot 2021-12-20 at 6.47.11 am


The creation of the row would fail if one of the variables (inputs to the row) is null or the sheet is expecting a certain type for a column but you are feeding this column with a type other than text or the preset type.

One way to test is to use the create row with only one variable and check the result then add the next variable to see which one is causing it to fail.

1 Like

Thanks muneer, that did the trick.

I updated the code to this to fix the problem.