Error when trying to import Android keystore

Hello thunkers.
I want to work on a future update on my soon-published app (on review for 2 days on Google PlayStore as we speak). So i exported .keystore that i need to import on another copy of app (i wanna keep the original previous app as well, not to mess up things when modifying, just in case).
Any copy will get another .keystore, naturally, so the next step is to import that saved .keystore from original.
But when im trying to do that, i get:
My first thought is that i cant have on my portofolio 2 apps with the same .keystore at a time ? :thinking: (thinking that keystore is like a unique index for my apps). So a workaround will de to delete original, make a copy that will get another keystore, and import original keystore only when needed just before upload on PlayStore. (need to have extracare not to loose first original keystore for that :face_with_hand_over_mouth:)
I dont want to mees up things so here i am, asking for opinions from you, as im just a beginner in this kind of things.
Thank you.

Hmmm… haven’t seen this error before @mimostel But I thought that keystores are on a per-account basis rather than a per-project one.

Are you updating an app from a different account or platform?

Are you using Google Play app signing?

No, nothing changed since im working on thunkable.

Dunno exactly what this means :thinking: but if you refer to my app, im not… My app is using SignIn component from Firebase (e-mail with password).

… then why every single new project (even copies) get different .keystore ? :thinking:

yesterday was that message from topic`s start, today, when ill try to import original key to my version 2 app i get this:


Later edit:
I tried to test if error is because .keystore acts as an unique identifier thru all my apps, or not.
So i made app A
Exported .keystore from A
Made B as a duplicate of app A (B got different .keystore, naturally)
Deleted app A
Made C as duplicate of app B
On this step, none of my apps have original .keystore
Tried to import to C saved keystored… and still this last error.

without solving this, cant upload new version of my app on PlayStore :roll_eyes:

1 Like

At the risk of becoming annoying, i wanna keep this topic alive cause my problem is not solved :roll_eyes:
After 5 days of waiting, my app is finally ready to be published

Im keeping it on hold, because i wanna push a hot fix first, but im stucked because of the issue.

Later edit: anyone else is facing this issue ? thanks.