Data viewer glitched?

Is data viewer glitched? Since the last update my code for data viewer is not working. I get a blank screen . I’m assuming this has to do with the update. any news on this front ?

Can you provide any information on how the data view is being populated (Design time, blocks, click events?). What is the data source (localDB, Google Sheets, Airtable) etc. What debugging have you tried so far? Pictures of your blocks and screen shots of the Live App are always worth a thousand words.

@rojroj101s - also, if the issue is with testing via Thunkable Live, don’t forget to check for updates first too!

I had the same problem today. I found out that it was because the data viewer was in a column that wouldn’t display the data viewer (even though the column was set to visible) for some reason it was causing the data viewer to not show …?

Anyways! After I moved my data viewer to a new column I could see it just fine. I hope this helps in some way!


When I remove the block [ In Data Viewer call Refresh Data ] my app starts working again and the data viewer is visable. I think this function is glitched. Because like I said this worked before one of the last updates.


@rojroj101s is this in Thunkable Live? Are you using the latest version (v255) of the app?

yes, this was in thunkable live. and I was using the most recent version. I did not try it yesterday or today. but I can try it again incase a new update was released.

I tried one of my test samples which has the refresh method and it worked in my mobile using the Thunkable Live App.

1 Like

I just tried it again and i get a white screen when I use this block. if I take the block out it works fine. and my app is up to date im running android.

1 Like

See this.

It uses the refresh if you run it from the mobile. It works fine without any issues

1 Like

Thanks for the suggestion. I can do a workaround I suppose, like make a manual refresh screen. But the refresh function was easier and worked better up until up until it didnt… :frowning: would love to have it fixed

1 Like

@rojroj101s are you using the same set up as @muneer ?

1 Like

Ive been stuck for weeks now, please help. 99% sure its a glitch. I’m losing my mind. So I’m not sure if its the refresh button now or the data viewer itself…this was working and its so basic literally no blocks needed and it fails… But, heres my situation in more detail.

I have my data viewer connected to my Airtable. I have a list of 100 items in airtable I want to display when screen opens… But, when the screen opens only the first 10 items appear. (all of them used to appear no problem no blocks just connect the data viewer and open the screen)

Weird part: when I change screens and go back into the screen then it loads all 100 items correctly.

side notes:
(My Data Vewer list is located in a tab navigator )
(I have no blocks on this screen)

1 Like

Can you test taking the screen out of the tab navigator and see if it works as expected. Although it might not sound connected but lets exclude this possibility and see where it actually fails.

Good idea,

But still did not work. It is still only displaying the first 10 items.

When I slide down to refresh it. the loading icon is shown but it only displays the first 10 items still. When I hit back button or change screens and go back in. it still only displays the first 10 items.

Weird part:
When the screen was in the tab navigator and I switch tabs and went back into the screen it would load all 100 items perfectly.

1 Like

Hi, I want to support your point as I experienced the same issue. In particular, it appens with the Data List viewer - not with the Data Grid viewer. Meaning that I manged to change the data viewer and I solved it in this way.

But for sure, this is something that needs to be fixed - among the other issues. Hope soon!

1 Like


So, I wanted to try this. So, I switched over from the data list viewer to the data grid viewer and now it took the first 20 items from my airtable and displayed them. Since its 2 items per row, thats still 10 rows. Does this have something to do with only reading and adding and displaying 10 rows instead of all row. I’m so stuck : (

Something is very wrong here and I really dont think its on my end…Thunkable…

1 Like

I remember there was a post with the same issue and again it was 10 rows the first time. I need to search that port to see if there was a solution.

1 Like

remove data refresh if you have it