Data Source Tables are *still* BROKEN!

Hi there,

I have been having problems with my app that has not been substantially changed in 2-3 weeks; some cosmetic changes only. I believe it is the Data Source tables themselves causing the problem. :roll_eyes:

As a sanity check, I borrowed Darren Alderman’s Brain Dump 2.0, thanks @darren. First fired it up, works great. Created a new Data Source table similar to his, and it does not work any longer. So I went back to using his original tables and guess what? Now they don’t work either. :unamused:

I’ve tried Tables, Airtables on new and old projects, they crash or just don’t work. :worried:

The original Brain Dump 2.0 that I borrowed, is located here:

The modified version is here:

The ONLY difference is the To Dos table, I didn’t touch the code or the design.

  1. Pressed “Add New Item”, type in new item name, pressed Save, works every time.
  2. I added a new table called ToDosToo with the same column names.
  3. I changed the DB Table calls from “To Dos” to “ToDosToo”.
  4. Pressed “Add New Item”, typed in new item name, pressed Save, app crashed.
  5. Went back to the original “To Dos” table throughout the DB Table calls.
  6. Closed the app, re-opened app.
  7. Pressed “Add New Item”, typed in new item name, pressed Save, app crashed.

I’ve done this twice with TWO copies of Brain Dump and the same thing happens with each copy. I also note that using the same Data Source Table name in multiple apps will result in the same data showing up. I don’t think it should do that. :confounded:

I tried Airtables and no joy there either. Wouldn’t work, and when I copied the project, the tables came across as Data Source Tables with no Airtable icon, and each and every cell reads “Thunkable”. :woozy_face:

I have reported this to Support until my fingers bled, (they just ignore me now) but they don’t want to believe anything other than “it should work now.” :face_with_raised_eyebrow: It does not work, and this has been going on for weeks…literally. I’m dead in the water with an app that is ready to be released.

I’d love to be wrong, cuz my app would work again. I appreciate any help I can get. :pleading_face:

Oh, and I did file a bug, #654, eight days ago…that has not been addressed. :weary: