Can't install Android apk on phone (worked before...)


Since 5 days, I can no longer install one of my android app project on my phone, in order to update the previous version. After installation loading is over, message “App not installed” appears.
But I’ve tried with another project, and… it installs normally.

Can someone help me on this? Thank you!

This happens to me too , but when i blindly publish the .aab file to play store i can download my app

Thank you for the tip!
If possible, I would prefer to avoid publishing my current unfinished project XD

Guess I’ll have to adjust my app only with live test until the lauch on Google Play…!

I have encountered this problem before. In 2020/10, you must make sure that you do not use special symbols and start with lowercase English letters for the installation file name.
Like “abc.apk”.
Of course there is an updated version 1>2 (The version name is not required)

Thanks Tony! Still doesn’t work, unfortunatelly…

I think I’m just gonna continue and hope it changes by itself soon…

You can try uploading to the Google cloud, the android app version has a built-in installer.
The main file cannot be decompressed or becomes a folder file.

Thank you Tony, I’m gonna try this.
This is so annoying, I’m gonna give up my pro account since it brings nothing more anyway…

It happened to me too. let reach thunkable staff

Any issue in back end system or new rule that we never know about it.

The only times I’ve seen this are when there’s an invalid package name or if you’re out of space on your device.

I’m guessing that you’re not out of space though?

If you delete your project and then re-download + install does that work?
What about making a copy of your project and seeing if you can download/install the copy?

Let us know if any of those works,



It also happens if you already have an older version of the APK is already installed and the bundle ID is changed in the latest download.


When I delete and re-install the app, it works.
But when I try to install an update of it, it doesn’t.

This problem occured after I duplicated the app on Thunkable last week, if I remember correctly.


As I have explained, this happens due to bundle ID which you can fix in the project settings.

1 Like